Installing Home Assistant Supervised on a Raspberry Pi with Debian 11

Not sure what you mean with ‘controller’ in this case but doesn’t this msg apply to the sdcard?

I’m using a rpi4 along with a StarTech 2.5″ SATA to USB 3.0 Adapter.

Looks to me like this issue is ‘normal’ at the moment because of this debian installation method. See regular warnings `mmc1 timeout waiting for hardware cmd interrupt` · Issue #1556 · raspberrypi/firmware · GitHub

I am thinking of moving from the Home Assistant OS install to a supervised installed due to problems with updates of the HAOS after 5.4 causing freeze issues. I have read your guides on installing HA with Debian and also with the now unsupported RPI OS.

I am confused on which is a better option and in hoping for some good advise.

  1. I see that Debian is fully supported by Home Assistant. What does this mean, other then the document stating that this is the supported install?

I have been using the SSD boot which for me works great up to OS 5.4. Any release after this causes Pi Freeze issues. Reporting issues on Github was met with a response that this is an unsupported install. I then changed to the Spit Sd / SSD install with the HA OS which is said to be fully supported and I and many others have the same Pi freeze issues. This has been ongoing since November.

  1. I have seen comments on new Debian releases that broke Home Assistant. Not sure how releases of Home Assistant and Debian are tested to ensure that HA works correctly?

  2. RPI OS is written for the Pi and it is definitely fully supported as an OS for the Pi. It is a customized Debian that is optimized for the PI. Why wouldn’t this be the best OS to use for the Pi and to install the HA supervisor?

I do see that new releases may be an issue but not sure why this is worse than new Debian releases?

Advice from experienced supervised users would be greatly appreciated.

Bill

None I am aware of. THere have been 2 recent docker versions that did though. It’s not hard to roll back if this happens.

HA is specific about the required OS version. I think a 64bit RPi OS may be reported as Debian… but Debian is the only supported OS for a Supervised install other than HAOS of course. The RPi OS is not the best because it’s not Debian…

You are incorrect it was not an issue with a docker release. It was an issue after updating Debian.

I’m not sure about the benefits of using the supported OS vs the OS that is optimised for the PI?

I am using the supported HAOS and I and many others have PI freeze issues after a few hours. I have been working with one of the developers trying to figure out a solution. The only thing I know so far is the kernel was changed along with other things after 5.4. From then on my system freezes after several hours.
I have just tried the dev 0S 6.x and it still doesn’t work correctly.
Saw many posts about the benefits of the RPI OS, GPIO for example and am not sure they are out weighted by using the “supported Debian”?
I value your input as you are very knowledgeable using the supervisor.

I now question again about which is better for the PI as PI releases are tested for the PI.
Thanks.

Thanks. I found that have some issue with USB boot using a USB 3.0 Flash drive on the pi3B…it makes everything incredibly slow for some reason, even though dd test shows “fast” read/write. Probably would be much faster if I just use the SD card.

If you are booting via a USB just putting in a blank SD card fixes this problem for me

1 Like

I have gotten it to boot after reboot with the same adapter
You have to change the /boot/cmdline.txt part of root=LABEL=RASPIROOT
by root = PARTUUID = XXXXXXXX-02
which you get by typing when you first install “blkid”
To make the change, you can do it with the SSD disk placed in a PC

I have the same issue with a StarTech adapter. Any fix for this?

I just saw others are having issues with a resent debian update where after the update the pi 4 will not boot off the usb.

“So I run Debian on RPi 4 8GP from an m.2 connected to the usb 3 port of my Pi and ran an apt update upgrade today 4.4. that results in the dismount and failure to detect the usb device on boot. As I am not that familiar with linux I spent a few hours trying to figure out what the upgrade does, but to save others the trouble of figuring a quick and dirty workaround. The upgrade adds a new initrd.img-5.10.0-0.bpo4-arm64 in the firmware partition.”
This is what I was talking about when I questioned rpios vs Debian. I experienced this same issue trying to run supervisor on Debian. After the update it would not boot off of the usb.

hi… is there any fixed on Debian?

Not that I know of. Still holding back linux-image-arm64 here and all is good.

As I wrote before one has to wait for initramfs-tools version 0.140 to be released for buster (still version 0.133 as of now) before updating the kernel. It got already released for bullseye though.

Maybe we have to wait until it shows up here?

I tried this on a fresh install and you need to upgrade to install SUDO, Not sure how you do this with 2021-03-04-raspios-buster-arm64? apt install sudo -y doesn’t work.

Can’t run this command on a new install following the directions above. Need Sudo install first and this fails without the update. What needs to be done on a new install?

Where did you get 2021-03-04-raspios-buster-arm64 from? That seems to be the wrong image. For the Raspi 4 4GB you need the latest image from here which is:

The first thing you do after just having installed Debian is to go to the CLI and type:
apt install sudo -y

Only after that you initiate:
sudo apt-mark hold linux-image-arm64

After the two above steps you can run:
apt update && apt upgrade -y

Read the OP’s instructions carefully. This guide is not for RaspiOS but for HA Supervised on Debian 10 Buster.

I figured it out.

Looks like the install worked, the snapshot worked but I am having an issue trying to get Samba to work. Followed the linked samba directions and I get

 sudo service smbd restart

sudo: unable to resolve host rpi4-20210210: Name or service not known

Not sure where to fix this?

Hello, If I well understood, your instructions fix the issue of a RPi4 hanging after “random crng init done” message while booting from SSD (no microsd), for a new install.

But how to fix an already installed Rpi4/Debian/HA supervised on ssd and no more booting after Debian update without starting from scratch?

Thanks

If you have already done the reboot after the kernel update to 5.5.10 and the RPI4 is stuck within the boot process now there is little that you can do left. Debian images are loading kernel and initramfs directly from RPI firmware without using a bootloader like i.e. Grub thus not providing any choice to boot from an older kernel.

I’m afraid you have to redo the whole OS installation from the start. Take care:
You must run

apt-mark hold linux-image-arm64

BEFORE running the first regular system update or else the installation is doomed again and the system will not start!

Nah that’s not needed @Tamsy

@unlikely
You can connect the USB drive to your computer and edit the boot.cfg file and change all 5.10 references to the 5.9 filenames (the 5.9 files should be in that directory as well)

[email protected]:/boot$ ls -ltrh
total 100M
drwxr-xr-x 4 root root  16K Jan  1  1970 firmware
-rw-r--r-- 1 root root  22M Dec 31 16:19 vmlinuz-5.9.0-0.bpo.5-arm64
-rw-r--r-- 1 root root 243K Dec 31 16:19 config-5.9.0-0.bpo.5-arm64
-rw-r--r-- 1 root root   83 Dec 31 16:19 System.map-5.9.0-0.bpo.5-arm64
-rw-r--r-- 1 root root  26M Mar 13 14:10 vmlinuz-5.10.0-0.bpo.4-arm64
-rw-r--r-- 1 root root 246K Mar 13 14:10 config-5.10.0-0.bpo.4-arm64
-rw-r--r-- 1 root root   83 Mar 13 14:10 System.map-5.10.0-0.bpo.4-arm64
-rw-r--r-- 1 root root  27M Mar 30 06:30 initrd.img-5.9.0-0.bpo.5-arm64
-rw-r--r-- 1 root root  26M Apr  4 04:16 initrd.img-5.10.0-0.bpo.4-arm64
[email protected]:/boot$ 
2 Likes

Nice to know that :slightly_smiling_face:

But where to find the file boot.cfg? I know this file from VMWARE only. On other modern Linuxes you can set boot options through /boot/grub(2)/grub.cfg but Grub is not available for Debian on arm64.

Thanks. Really hoping to save my current installation. Where can I find that file?