Installing Home Assistant Supervised on Debian 11 Bullseye

I am trying to install HA Supervised on Debian 11 but running into a problem when I get to the actual step of installing the .deb file.

Running dpkg -i homeassistant-supervised.deb results in the following message:

Error response from daemon: Get "https://registry-1.docker.io/v2/": dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:60553->[::1]:53: read: connection refused

I have confirmed that this does not happen on Buster with the same Pi. I have also forced specific DNS servers such as 8.8.8.8 and 8.8.4.4, rebooted and restarted Docker with no success. Any help would be appreciated.

Here’s what I experience on Bullseye with build date 2021.08.23:

[email protected]:~# dpkg -i homeassistant-supervised.deb
Selecting previously unselected package homeassistant-supervised.
(Reading database ... 28024 files and directories currently installed.)
Preparing to unpack homeassistant-supervised.deb ...
[warn]
[warn] If you want more control over your own system, run
[warn] Home Assistant as a VM or run Home Assistant Core
[warn] via a Docker container.
[warn]
[warn] ModemManager service is enabled. This might cause issue when using serial devices.
Adding 'diversion of /etc/NetworkManager/NetworkManager.conf to /etc/NetworkManager/NetworkManager.conf.real by homeassistant-supervised'
Adding 'diversion of /etc/NetworkManager/system-connections/default to /etc/NetworkManager/system-connections/default.real by homeassistant-supervised'
Adding 'diversion of /etc/docker/daemon.json to /etc/docker/daemon.json.real by homeassistant-supervised'
Adding 'diversion of /etc/network/interfaces to /etc/network/interfaces.real by homeassistant-supervised'
Unpacking homeassistant-supervised (1.0.2) ...
Setting up homeassistant-supervised (1.0.2) ...
[info] Restarting NetworkManager
[info] Restarting docker service
ping: version.home-assistant.io: Temporary failure in name resolution
[info] Waiting for version.home-assistant.io - network interface might be down...
ping: version.home-assistant.io: Temporary failure in name resolution
[info] Waiting for version.home-assistant.io - network interface might be down...
PING version.home-assistant.io (172.67.68.90) 56(84) bytes of data.
64 bytes from 172.67.68.90 (172.67.68.90): icmp_seq=1 ttl=59 time=12.3 ms
--- version.home-assistant.io ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 12.274/12.274/12.274/0.000 ms
[info] Install supervisor Docker container
***Error response from daemon: Get "https://registry-1.docker.io/v2/": dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:60553->[::1]:53: read: connection refused***
**dpkg:** error processing package homeassistant-supervised (--install):
installed homeassistant-supervised package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
homeassistant-supervised

The error message you show definitely seem to indicate the DNS is pointing to localhost, though.

I don’t think that’s the case. I have verified that localhost is not used for DNS and I can execute docker run hello-world without an issue.

try this:


nmcli con edit "Home Assistant OS default"
set ipv4.dns 8.8.8.8
save
quit
ha host reboot

That’s actually how I set the DNS but I also set the option:

ipv4.ignore-auto-dns yes

What does cat /etc/resolv.conf tells you?

I figured it out. The locale needs to be set for Bullseye before installing Docker.

I followed the instructions from this Serverfault answer including a comment that says to run update-locale LANG=en_US.utf8.

BTW, @koying and @francisp : I really appreciate you both trying to help. :grinning:

Err… I wonder how you linked that error message to a locale problem :joy:

I am having the same issue and don’t know too much about docker and settings Locales.
However I followed the instructions in the link but still no luck…

Did you need to uninstall Docker and OS Agent,
then set the Locale,
then reinstall Docker, OS Agent and homeassistant-supervised.deb?

You need to set the locale first and then reboot before installing Docker. That’s what worked for me.

Also, I think running apt upgrade at the moment will cause the HA install to crash Debian. Need to validate this further, but have not had time.

you can try my scripts to help you install it.

you can find it GitHub - tirtadji-com/rpi_debian_ha_supervised: Installation for official Debian running Home-Assistant Supervised

I came across this thread looking for a solution for the same error and solved it in a more radical way…
Was installing a fresh Debian 11 on my server and no matter what I was unable to download the containers (but hello world container downloads and run just fine):

--- version.home-assistant.io ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 30.098/30.098/30.098/0.000 ms
[info] Install supervisor Docker container
Error response from daemon: Get "https://registry-1.docker.io/v2/": dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:60704->[::1]:53: read: connection refused
dpkg: error processing package homeassistant-supervised (--install):
 installed homeassistant-supervised package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 homeassistant-supervised

The error is probably related to DNS but even installing resolve.conf as service and set my DNS nameservers permanent dpkg/docker refused to install the containers.
Lucky me, I still had a copy of Buster’s iso… I’ve installed it again, did a complete installation process for the supervisor with no errors and then I’ve updated the distro to Bullseye.
All it had taken was 20-25 more minutes including merging my HA backup and now all is updated and is working fine.

F.