Installing Home Assistant Supervised on Debian 11

nope…just used that docker run and all works as expected

Ok, I will look into this workaround and see how it plays out. Thanks for this suggestion.

As for the main issue with CoreDNS conflict, I hope the devs look into it. A little beyond me.

See the funny thing is, even when running PiHole as a container, Listening port is going to be TCP/UDP53. So I don’t think it is a port conflict, as that setup is working working for you. There is probably more to the story.

Just starting from scratch again, the detected network hardware throws the missing firmware files: rtlwifi/rtl8192.bin. If I select NO here then the install process goes on to the Configure the network and shows me the Gigabit Ethernet Controller and also the Wifi Adaptor (wireless). so I select the WiFi adaptor and connect to the wireless network and continue through the installer process without any errors being shown.
However at the point of pulling the USB and restarting the machine is where things stop working according to the “plan”.
Yesterday I was trying with the latest installation of Ubutun, had the same wifi driver error but that did not stop the OS from booting at the end and on its first boot up. But when I then followed the above Docker and HA installation instructions, it failed on the HA steps. So I thought that I would follow exactly step by step using the Debian image. I was hoping to set up a headless installation like explained by @DavidFW1960 but not there yet…still a lot of things to learn!

So I know that I need to install that .bin firmware but I just cant find any where how to do that,…any guidance please :slight_smile:

I would install Debian 10 using wired ethernet. Then I’d add the required wireless driver and then I’d install docker and home assistant using the guide you’ve already been following.

I managed to get some steps further, during the installation I inserted another USB with the required Wifi driver and it seemed to get installed. In face the system now boots without the previous error! However I dont think the WiFi or LAN connections are connected to the internet, no flashing LAN port lights and when i run “ip a” the INET is showing 127.0.0.1/8 scope host lo. I also can not find the computer on my network when using FRING.

How to force a wifi connection? during the installation is all seemed to be working and connected to the internet for the “Configure Package Manager” during the initial installation. I remember that on a Raspberry pi I would copy a wpa file on the root and then boot to connect to my home wifi. Is it the same or similar for Linux Debian?

Are you certain abt that ?
Pihole would be listening on port 53 of the docker host ,
CoreDNS would not. It would be listening inside the docker host for dns requests originated by HA I would think.

Looks like the issue is more in regards to hassio-supervisor’s access to Host IP eth0 based services.

I have updated my original post with my findings. I am guessing the first time it failed is because when hassio-supervisor tries a new DNS request, it does not use updated DNS resolver, unless you restart the container after updating the DNS resolver.

Anywho, the problem seems to be more on network side of the things, where hassio-supervisor container is unable to access host network based services.

That should be an easy fix with a new composer file, if devs wish to fix it.

Correct, and container 53 will be NAT’d to host 53, because your network devices will be sending requests to your host’s 53, not container’s 53.

This is not what the instructions call for. The image you want is this (or the most recent which is 10.9), as per the guide.

debian-live-10.7.0-amd64-standard.iso

Try using the correct image, and don’t run your Home Automation server on WiFi.

1 Like

That is why I us th Debian image containing th non-free firmware instead of the standard disc1 iso

Thank you @kanga_who and @DavidFW1960

I was only trying to use the wifi for installation and set up, in the final server location it will be on LAN connection. Sorry, its very confusing for a non compturised person to try to find out all the correct information. So please could you guide me on the “correct” installation name of Debian that I should download and flash? I found this website in my quest to get this working ( Index of /cdimage/unofficial/non-free/cd-including-firmware/10.9.0-live+nonfree/i386/iso-hybrid ) which seems to have most versions but there are so many to choose from. I went with this version and get a full installation without any Kernel or wifi driver errors, ( debian-live-10.9.0-i386-standard+nonfree.iso). No red lines when I run “sudo dmesg”, it installs straight through but still no internet after the installation. I managd to turn on the LAN port with Sudo ip link set dev enp1s0 up" and the lights on the port are flashing but the machine does not get a handshake and no IP DHCP is shown when “sudo ip a”.

I really appreciate that this is not really within the guidance of this thread and topic. but if you could guide me on the installation to use (a link would be superb) then I wont post any ore here unless about the docker and HA installaton…that I haven’t even started attempting yet :slight_smile:
THax Chris.

I would grab this one here
https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/current/amd64/iso-dvd/

(Note that this turns out to be a link I posted earlier in this thread)

1 Like

I run the same hardware as you do on my production HA, and used the netinst method for installing Debian, without the non-free firmware, and have no issues.

I’ve updated my VMware dev instance to Debian 10.9, but a bit reluctant to update my hardware-based installation at this stage - can’t find any reference to anyone who’s done it yet

no issues but you will find errors in the log regarding wifi but no issue if you don’t care or don’t want to use it.

Pretty much most people running supervised on debian are likely to have updated. I did as soon as it came out in fact I check for updates at least once a week and always keep my system up-to-date.

yeah, it’s weird - I never loaded the non-free driver for WiFi, but I’ve also never seen anything in the Debian syslogs…

I’ll do an upgrade now :slight_smile: - thanks mate

I got this installed. But it seem that I cannot installed anything from “add integration” I have tried several. I got deConz by going to supervisor and using add on store.

edit: problem solved.

I’ve successfully got Home Assistant Supervised running on a VMM virtual machine, and as far as it goes it has no issues by itself. However, I was also running OpenVPN under Synology’s VPN Server package, for quite some time now and OpenVPN clients have been having issues authenticating when the VM is active.
After reaching out Synology’s support, they’ve directed me to this error log and pointed out there could be an issue with this VM (specifically with the docker container for “Home Assistant”) and OpenVPN:

2021-05-10T09:10:09+01:00 my_nas openvpn: Libgcrypt warning: missing initialization - please fix the application
2021-05-10T09:22:55+01:00 my_nas synoscgi_SYNO.DSM.Network_2_list[21908]: dbus_client.cpp:37 Failed to get bus connection
2021-05-10T09:22:55+01:00 my_nas synoscgi_SYNO.DSM.Network_2_list[21908]: dbus_client.cpp:37 Failed to get bus connection
2021-05-10T10:05:24+01:00 my_nas synoscgi_SYNO.Virtualization.Guest_1_set[17674]: Guest/guest.cpp:2093 Guest: [MY_VM] edit: [ISO Images edited]
2021-05-10T10:08:38+01:00 my_nas synoscgi_SYNO.Virtualization.Guest_1_set[23825]: Guest/guest.cpp:2093 Guest: [MY_VM] edit: [ISO Images edited]
2021-05-10T10:09:04+01:00 my_nas synoscgi_SYNO.DSM.Network_2_list[24855]: dbus_client.cpp:37 Failed to get bus connection
2021-05-10T10:09:04+01:00 my_nas synoscgi_SYNO.DSM.Network_2_list[24855]: dbus_client.cpp:37 Failed to get bus connection

The issue does go away if the VM is shutdown.

Does anyone have any idea what’s going on and what can be done to sort it?

Your issue is to do with a VM/Synology/OVPN, so being that the guide is not intended to be used as a VM, and you have introduced other potential issues to the installation, you would probably be better off starting a new thread.