Installing Home Assistant Supervised using Debian 12

Thank you very much for these instructions.
Very good job.

In reference to this, is there a way I can use SSH to do this? For some reason I am unable to access the host system and cannot exit the Home Assistant CLI to do any updates to Debian.

Thanks, in advance.

you need to either install the ssh supervisor addin in HA…or apt install openssh-server on Debian. Then sign in. If you get a message that you aren’t in the sudo group,

su -
usermod -aG sudo youruserid 
1 Like

GOTCHA! Okay thank you so much. Have been racking my head on this one and have been going down rabbit holes that lead nowhere.

Is the ssh supervisor addon different from SSH & Web Terminal? I can’t find anything in the addon library that’s SSH Supervisor

sorry…yes use ssh & web terminal addon.

That’s what I am using, but I cannot exit the HA CLI. I have no way to access the host machine through SSH & Web Terminal.

I even disabled Protection mode, and restarted thinking that would help but no dice.

So what port are you using for the addon? Note Debian by default will use port 22 for the host ssh and the ssh addon will also want to use port 22 by default so an ssh client can only connect to 1 port 22.

I set the ssh port on the host to be not port 22 anyway and I also have the addon using a different port so I can connect to the host ssh to update debian and can also connect to the ssh addon on a different port to say update ha.

Ahhhhhhh got it, yea that makes a lot of sense.

Am I able to just change the port in the addon without breaking anything? Or is it better to set the port directly through Debian and keep the port 22 for the addon?

I change both as it’s a security risk using a common port like 22 anyway. But easiest is to change the addon port. It won’t break anything.

1 Like

Makes sense, I’ll probably do both eventually, but will start with the addon port. Thank you for help. Definitely one of those “DURHHH” moments. Insert facepalm here.

1 Like

This is a very good question.
Trying to get my gpio/one wire sensor seen and working on my Pi4 64 is driving me bonkers. Worked fine before following this “official” supervised install guide.

Did anybody try recently installed debian-live-10.9.0-amd64-standard.iso and end up with success? I spent today a half day on trying to have a fresh installation and no luck at this time. I tried to put that Debian on USB HDD as well as on 64GB SD card (flashed by Rufus, Balena and even Rasp tool) and at every time it didn’t want to boot. On the contrary, I tested the same SD card with Raspberry Pi Imager flashing the HASS OS 5.13 from the menu and it booted immediately. Half year ago I used Debian 10.7 and it has booted installer at the first attempt. It would be strange if these two versions (10.7 vs 10.9) could differ, but any idea, why it does not boot (even from SD card) for me, I would appreciate. If you know a link to that older version of Debian I would test it as well would this work for RPI4+USB (as I had it up to yesterday)

RPi4 is an ARM architecture, not AMD64.

and last time did work for me. Need to try find the other version and test it.

1 Like

Anyone here has experience with upgrade to

docker-ce-cli/buster 5:20.10.7~3-0~debian-buster amd64 [upgradable from: 5:20.10.6~3-0~debian-buster]

docker-ce-rootless-extras/buster 5:20.10.7~3-0~debian-buster amd64 [upgradable from: 5:20.10.6~3-0~debian-buster]

docker-ce/buster 5:20.10.7~3-0~debian-buster amd64 [upgradable from: 5:20.10.6~3-0~debian-buster]

I’ll let you know…upgrading now. Note: lots of firefox security updates]

update: no problems…everything running OK including HA and pihole

Been running fine for weeks since release

Thanks for the info!!!