Installing Home Assistant Supervised on Raspberry Pi OS

Tags: #<Tag:0x00007f7399ef8198>

I can confirm HA 111.4, RPi4 on USB 3.1 boot drive is running well and smooth. I have a HUSBZB-1 for z-wave and zigbee which still working with no issues, plugged directly into a usb 2.0 port on the Pi as well.

Now we can finally boot a Rasberry Pi 4 native from an SSD, but when you also use a Conbee or Raspbee stick for your Zigbee devices they won’t always work. The firmware will say “not connected”. This video shows you how to solve this and it is SUPER EASY!!!


i just created a user for this forum in order to get some help if possible.
I follow the whole guide thill the last command
"curl -sL “” | bash -s – -m raspberrypi3 "

and i got this as result :

" [Info] Install supervisor Docker container
[Info] Install supervisor startup scripts
[Info] Install AppArmor scripts
[Info] Run
[Info] Install cli ‘ha’"

but if i check my IP and port i don’t see Home Assistant. I do assume this guide is to install Home Assistant from scratch right ? And not only the Supervisor.

Can someone, please, help me out ?

Many thanks!

How long did you wait after running that script ? HA still needs to be downloaded and installed, can easily be 20 minutes before you can access

Thanks for your answer! i did wait but i guess something went off. I started from the scratch and now it worked :slight_smile: That’s why i took a while to reply… i wanted to be sure before waisting your or other people time :slight_smile:
It’s finishing up so it should work after that! Thanks a lot!

Would you please tell us what did you do to boot directly from SSD? Is there a way to install Home Assistant on a RPi4 booting from an SSD without SD card? No Raspberry Pi OS, Docker, Supervisor.

Thanks a lot @kanga_who, chapeau to you.
I got a new RPi4 8GB and this tutorial helped me from start to finish. Clear steps, easy to follow.


1 Like

Hi everyone. I have a strange problem with this kind of installation.

After installing Raspberry Pi OS, i have assigned the static IP in the dhcpcd.conf file. That IP is outside of the DHCP range of my router. I have used Raspbian without Home Assistant for several days without problems, and it has only the fixed IP (

The problem begin when I installed Home Assistant Supervised because it needs NetworkManager. After installing docker, NetworkManager and Home Assistant, i have observed that i have 2 IPs for my Raspberry, one i had fixed outside the DHCP range ( and other one within the DHCP range.

I think DHCPCD get the fixed IP, and Network Manager ask a DHCP for my router, i don’t know why.

have any of you had this problem? How have you solved it?

Hi, 30 is usually a number out of range dhcp router

Hi, Can anyone help me with the following problem?
when restart HA does not finish and shows

however if I reboot the entire system boots normally

Raspberrypi OS + hassio + SSD

at the moment the folowing works and fixes it:

‘sysctl net.ipv4.igmp_max_memberships=80’

Using this installation method, I can’t open GUIs from addons, it just shows

500 Internal Server Error
Server got itself in trouble

Any idea how to fix or debug?

Which addons? Do they use ingress?

e.g. deConz or Portainer, I think that they use ingress yes

I have problem with RBpi4+docker+hassio.
I instaled hassio step by step, and it works well… almost, i cant integrate mysensors.
Have problem with persistence file, i got such warning in log: “File does not exist or is not readable: /home/pi/docker/hassio/homeassistant/mysensors.json”, and after few seconds error “Permission denied when writing to /home/pi/docker/hassio/homeassistant/mysensors.json”
When i install hassio from image i didnt have any problem, but i need VPN on my RBpi, so have to install hassio on docker.
Any idea, can some one help me?

If you review the instructions in the first post of this thread, you’ll notice it never mentions “”. That’s the old name for what is now called Home Assistant OS and that’s not the topic of this thread which is Home Assistant Supervised (on Raspberry Pi OS).

There’s no such thing. is Home Assistant OS and that already contains docker. You can’t install it on docker.

You may wish to review the information here. It describes the four officially supported installation methods for Home Assistant.

Lastly, I may be wrong but your question appears to be related to a problem you have encountered with the MySensors integration, specifically a file-access problem. You may wish to post that in its own thread so that other MySensors users can see it and help you (because it’s kind of buried here in this thread).

1 Like

You need to use nmcli to configure the network for a static IP. If you only use the wired connection, you can turn off the Wi-Fi module with sudo nmcli radio wifi off as well.

1 Like

@kanga_who Which USB SSD are you using to boot? I’m looking at SanDisk Extreme PRO 128 GB Solid State Flash Drive, USB 3.1(Gen 1).


I have 2 that I use for testing (I don’t run my main HA on a Pi).

I have a 64gb Kingspec Z3 USB-C SSD, and also use a WD Green 120gb SSD in an Orico USB3 enclosure. Check this site for a list of known working enclosures.

1 Like

Did you forward your ports?