Installing Home Assistant Supervised on Raspberry Pi OS

sorry it does stop execution here is the full output:

root@raspberrypi:~# curl -sL “” | bash -s – -m raspberrypi4
[info] This script is taken from the official
[info] Home Assistant Supervised script available at

This looks incorrect. It should look like this.

-- -m raspberrypi4

Copy and paste it directly from the instructions.

Discourse does that stuff.

So have you gone to http://ip-address:8123 ? It is probably installed and running…

no good, i dont see anything running.

All fixed. Now addon store isnt loading.

Thank you so much for this. I installed this on a 120Gb SSD that boots on a Raspberry Pi 4 and it works perfect.
But the Home Assistant Core is on version 0.108.6.
I want to upgrade my home assist version but not to the latest one
Can you please help with a upgrade procedure to a specific version ?
Thanks a lot

Hey guys,

Are you finding that HA device location doesn’t update? I keep getting my device trackers (from my phone) saying that I’m at home all the time. I switched to HassOS and everything works fine i would like to have access to Raspbian which I’m missing.

Also once you install this on PiOS are you finding that the pi sometimes freezes and you have to force reboot?

Finally, what is the difference between

curl -sL "" | bash -s -- -m raspberrypi3


curl -sL | bash -s -- -m raspberrypi3
Found on

I also came across another installer which installs docker and all the requirements together using a single script as well (by the guy with the Swiss accent) on a guide I found here

There are a lot of installers floating around and would be good to know what to follow and if there are any benefits/downsides to any of them.


I had copied the script and made an install guide back when Supervised had been announced as being deprecated. The script is 99.9% the same.

1 Like

fixed. as i’m running phiole on this device as well, you need to make sure you have “listen on all interfaces” checked in the PIHole settings to enable internal traffic to get to the dns…

went through all the instructions and it said it was up and running. waited about 45 mins the port is still not up. any troubleshooting steps i can take?

seems like this just keeps repeating: 
20-10-12 19:20:40 INFO (MainThread) [supervisor.plugins.dns] Setup CoreDNS plugin
20-10-12 19:20:40 INFO (MainThread) [supervisor.updater] Fetch update data from
20-10-12 19:20:45 WARNING (MainThread) [supervisor.updater] Can't fetch versions from Cannot connect to host ssl:default [Try again]

Having the same problem with the location


Hello, thanks for your continued support. I was wondering if you can advise on installing duckdns and letsencrypt for exposing HA to internet. Would be great if you can point me to a tutorial which can work with this setup.
I have already installed and configured duckdns
Portforwarding is enabled.
I can access HA on internet but want SSL with it plz.


Hi, Thanks for the article. I have made a fresh installation this way on raspberry pi 3, I want know the location of configuration.yaml, how can I access it if I have made an ssh connection via ‘pi’ user to my raspberry.

my ultimate goal is to share a directory as media directory, I suppose by using
media: /media
recording: /mnt/recordings


most likely your config will be in /usr/share/hassio/homeassistant

You can check it in portainer, in the volumes section of the homeassistant container. Check the location in the column host/volume in the same line where you find /config

Thanks for this - successfully installed on RPi 4 running Raspi OS 32bit booting from 120GB external SSD. Worked first go.

Does your device tracking working?

Thanks a lot for the guide, installed on pi os RPI4 2gb with 120gb ssd, working fine .
Is there any way to update the Addons latest version which are not available for update after this type(supervised “unsupported”?) of installation .?

i seem to have a problem with the installation. I am a complete noob with all of this just so you know.

I’ve followed the instructions and there weren’t any errors. The last thing I got after it was installed was:
[info] Home Assistant supervised is now installed
[info] First setup will take some time, when it’s ready you can reach it here:

The IP that this pi has should be but when i tried both in my browser nothing showed up. I also tried to see what docker containers were running which were the following.

root@raspberrypi:~# docker ps
CONTAINER ID        IMAGE                                                  COMMAND                  CREATED             STATUS              PORTS                  NAMES
d1a0ba096b21        homeassistant/raspberrypi3-homeassistant:landingpage   "/init"                  7 minutes ago       Up 7 minutes                               homeassistant
42024a8c759c        homeassistant/armhf-hassio-multicast:3                 "/init"                  9 minutes ago       Up 9 minutes                               hassio_multicast
c61043910b65        homeassistant/armhf-hassio-observer:2020.10.1          "/init"                  10 minutes ago      Up 9 minutes>80/tcp   hassio_observer
03c9d836e3c3        homeassistant/armhf-hassio-cli:2020.10.0               "/init /bin/bash -c …"   12 minutes ago      Up 11 minutes                              hassio_cli
4300007465cf        homeassistant/armhf-hassio-audio:17                    "/init"                  13 minutes ago      Up 12 minutes                              hassio_audio
ea461ff08ffd        homeassistant/armhf-hassio-dns:9                       "/init coredns -conf…"   15 minutes ago      Up 15 minutes                              hassio_dns
a69c0f137c8c        homeassistant/armhf-hassio-supervisor                  "/init"                  18 minutes ago      Up 17 minutes                              hassio_supervisor

Is it true that there isn’t a open port for the landingpage or any port containing 8123.
I hope someone can help me further with this.

*after I made this reply i looked into the active devices on our network and I noticed that there are now 2 raspberry pi’s showing with the IP ending in 166 and 161

On your local network you shouldn’t have that port blocked. Have you rebooted the Pi?

@kanga_who In the opening post, you have two links to

  • Install Samba, Portainer and MQTT on Ubuntu or Debian
  • Backing up and Restoring your configuration

But they both do not refer to the latest version (master) on github. The correct links are:

Could you change these links in your OP? Haven’t checked the other links.

:+1: thanks for the heads up