Installing Home Assistant Supervised on Raspberry Pi OS

For some strange reason, the links automagically changes in my post (and yours as well). I made a link to your master branch, but now the links in my post and in the OP have changed and refer to a 7aa3f36037 branch. This is apparently automatically changed?

@kanga_who - followed the instructions exactly, i think… got no errors, but i cant seem to connect to my raspberry pi on port 8123.

The only part of the installation that i was a little unsure of was 32 vs 64 bit. I have a Pi 4 8GB, i understand that there is no 64bit version of OS lite, so i installed 32bit OST lite. I then used the raspberrypi4-64 parameter. Not sure if thats a problem?

I’m coming from a Ubuntu Home Assistant Core installation background, new to docker, so im struggling to understand what is happening with the docker components and how to look for errors, where to find logs, etc…

this is what is see when i run “docker ps”

pi@raspberrypi:~ $ sudo docker ps
CONTAINER ID        IMAGE                                           COMMAND                  CREATED             STATUS              PORTS                  NAMES
2d65afc5b95e        homeassistant/armv7-hassio-multicast:3          "/init"                  12 minutes ago      Up 12 minutes                              hassio_multicast
356ca947e001        homeassistant/armv7-hassio-cli:2020.10.0        "/init /bin/bash -c …"   12 minutes ago      Up 12 minutes                              hassio_cli
082a8594220e        homeassistant/armv7-hassio-audio:17             "/init"                  12 minutes ago      Up 12 minutes                              hassio_audio
e23df9ca2aee        homeassistant/armv7-hassio-dns:2020.10.0        "/init coredns -conf…"   12 minutes ago      Up 12 minutes                              hassio_dns
234cb4752ff1        homeassistant/armv7-hassio-observer:2020.10.1   "/init"                  13 hours ago        Up 13 minutes       0.0.0.0:4357->80/tcp   hassio_observer
22fd6977c3c5        homeassistant/armv7-hassio-supervisor           "/init"                  13 hours ago        Up 13 minutes                              hassio_supervisor

Here I have this one also when use docker ps. Don’t see that one in your list

ffc4af86e7a7        homeassistant/raspberrypi4-homeassistant:0.116.4     "/init"                  13 days ago         Up 19 minutes                                                                            homeassistant

Start over. 32bit OS and 32bit HA. (Don’t add 64 to the end)

that did the trick, thanks!

1 Like

Hi Kanga_who,

Thank you for taking the time to prepare this guide, I have just followed it to install on a Raspberry Pi 4 and went so smoothly, had the whole install done and logged into Home Assistant within an hour. No issues at all. Top work. :+1:

1 Like

If my RPi4 currently is booting directly from SSD with raspbian, can I flash directly to SSD and it will still boot from it without any SD between?

You don’t need an SD card in the Pi, you can flash Raspberry Pi OS to the SSD, and the Pi will boot from the SSD. You can then follow the instructions to install Home Assistant Supervised.

Hello,
i am also new to all of this. Currently i have IOTStack running with a few docker containers.
Now i wanted to install the Home Assistant Supervised version and i used this guide above. But i get always the same error message :dial tcp: lookup auth.docker.io on 127.0.0.53:53: read udp 127.0.0.1:35722->127.0.0.53:53: i/o timeout"
Does anyone have an idea ?? I searched for 2 days now and could not find a solution. Here is a screenshot.


Thank you for your help !

Hello
I have the same problem for 2 days, it seems that resolv.conf is located /etc/resolv.conf but I tried to modify the file but nothing more.

Raspberry Pi4 with RaspberryPiOS Lite 20/08/2020
I try to install raspberrypi4 or raspberrypi4-64

Thanks

Hi,

With the help of a friend the problem is when restarting Network-Manager which does not have time to restart before continuing the procedure.

I forked my github and added a 20 second sleep to give it time to restart.

You can install via my fork

curl -sL "https://raw.githubusercontent.com/McFlyPartages/supervised-installer/master/installer.sh" >> hassio_install.sh
sudo bash hassio_install.sh -m raspberrypi4

I proposed a PR on the official github.

That issue has already been addressed I believe. I have just re-run this process again on my own Pi4 4gb, and it works as expected - no issue.

I just restarted the installation and it worked, but since yesterday I just restarted installations with the same problem.

It seems resolved

kangawho script error

I am having the same problem as above.
Also after installing Network Manager, my raspberry keeps on getting random MAC addresses on Wifi and changes IP at each reboot so I had to add the following file in NetworkManager/conf.d

100-disable-wifi-mac-randomization.conf

[connection]
wifi.mac-address-randomization=1
[device]
wifi.scan-rand-mac-address=no

It worked after commenting the NM restart and starting it manually after the script.
But still I get the following errors in the new instance:

This is hilarious, I have Raspberry OS, what is not ok now???

OMG. Your post just saved me! Thank you very much!! You cant imagine how thankfull i am. Tomorrow i would have resetted my whole raspberry ! Have a great day!

You’ve already answered your own question in this sentence.

20-11-24 03:44:54 ERROR (SyncWorker_7) [supervisor.docker] Dockerd connection issue for hassio_observer: UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=900)
20-11-24 04:06:54 ERROR (MainThread) [supervisor.plugins.observer] Can’t start observer plugin
20-11-24 04:06:54 ERROR (MainThread) [supervisor.misc.tasks] Observer watchdog reanimation failed!

I get periods of blackdowns in my sensor history graphs when this error happens for hours, any idea what is causing it?

Also do you advice to install the new update for the core?

I’m not sure what you mean? All HA updates are installed through the HA web interface, in the Supervisor panel…

I was meaning the update to 0.118.3, yes.
I still have this kind of error, is this ok or not?

20-11-25 09:02:36 ERROR (MainThread) [supervisor.core] Detected unsupported OS: Raspbian GNU/Linux 10 (buster)
20-11-25 09:02:36 ERROR (MainThread) [supervisor.core] NetworkManager is not correctly configured
20-11-25 09:02:36 INFO (MainThread) [main] Running Supervisor
20-11-25 09:02:36 WARNING (MainThread) [supervisor.core] System running in a unsupported environment!

The part about Raspberry OS I understand, but about Network Manager, why it is configured wrong and how can I check it?
Today I couldn’t communicate with the RPi over WiFi, I opened the TV connected to it and it had lost the Wifi connection.

If you search the HA website, you will find this, which states the following…


If you have not already, install Network Manager on the host.

When it is installed, you need to make sure it manages at least one interface see the documentation for the network manager.

Here are some example files that can be used to make the Network Manager control all physical interfaces.

/etc/NetworkManager/NetworkManager.conf :

[main]
dns=default
plugins=keyfile
autoconnect-retries-default=0
rc-manager=file

[keyfile]
unmanaged-devices=type:bridge;type:tun;type:veth

[logging]
backend=journal

/etc/NetworkManager/system-connections/default :

[connection]
id=Supervisor default
uuid=b653440a-544a-4e4f-aef5-6c443171c4f8
type=802-3-ethernet
llmnr=2
mdns=2

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

/etc/network/interfaces :

source /etc/network/interfaces.d/*

auto lo
iface lo inet loopback

You can also re-run the installer script.

sudo -i
curl -sL "https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh" | bash -s -- -m raspberrypi3

If you would like to run a supported installation on the Pi, follow this guide instead, and I would strongly recommend you use a network cable plugged into the Pi at all time, not WiFi.