Installing Home Assistant Supervised using Debian 12

When you run ip a, what does the entry eth0 show? you’ve cut off the top half of the information

Crap sorry - here.

Well, this isn’t the IP of the machine. Look at eno0 — inet…

1 Like

Feel free to laugh at me. Go on, go ahead, I deserve it


I SWEAR I thought it was 214. I would have bet money.

Thanks yet again for your patience.



If you are looking for help installing Debian on a Pi4, you can take a look at this guide which will help you install a supported version of Home Assistant Supervised.

Please correct me if I misunderstood something but,
The tested IMG comes “bare bone”, no DE.

If I wish to show my HA dashboard from a screen connected to the pi, I’ll have to install a DE & web browser, which will brake the supported installation.

So, that mean that there is no official way to power home assistant from a pi4 with a screen?

This guide is not for installation on a Pi, I linked you to the correct guide for that previously.

None that I am aware of. The normal use case is you access HA from a web browser on your phone, laptop, tablet, PC etc - not from the HA machine itself.

Just following through and at first step of HA install I get
“Package Network-manager is not available but is referred to by another package…”
“Package apparmor-utils is not available…”
and a cascading fail from there…

Any ideas?

Edit… after browsing some other instructions it would appear that network-manager doesnt have a package for x86 and only 64bit, so think i’m bang out of luck on this machine

Just wanted to check back in and say thank you.

Once I have forsaken my touch screen, I followed your guide to the letter and it didn’t fail to deliver.

Thank you for doing the extra mile for us folks whom need explaining like we are 5.

I hope that someday in the future we will get support for raspbian derivative , but now I understand that it’s not that trivial.

1 Like

Not a worry mate, I still get confused by HA regularly, even after using it for over 3 years.

Thanks for your work on this, any ideas? 10.6 debian fresh install.

EDIT fixed it… doh…

i’d installed docker manually, which I assume must do something with apparmor, started again and it was fine

at least mention what was wrong, it might help others.

First time using docker and this tutorial straight forward into making a functional home-assistant without hassle! Really thanks @kanga_who

Also for another user that build from very minimal linux distro (mine from debian-netinst without installing any additional components on setup phase), if you setup network using editing


I encourage you to install and setup network using network-manager before running the script, because the script will move to using that manager in the setup process.


I just spent some time migrating from Ubuntu to Debian. I had problems with getting a USB-to-serial device to work. After a frustrating afternoon, I found a process used for braille devices was grabbing the tty port. Here are the the CLI commands I used to remove it:

sudo apt-get remove brltty
sudo  apt autoremove

The second command clears out a few dependency files. After a reboot, all was back to normal.

Thanks for the tutorial.


I know this isn’t technically the purpose of this guide but it is related…

Have you ever looked into how to completely remove the supervised install from Debian?

I haven’t been hit by the “unhealthy” bug/feature yet on my test Supervised install but if I do then there won’t be any further purpose to keeping it around so I might as well remove it when it finally happens. But I’ve never seen anywhere on how to actually uninstall it.

1 Like

The only way I have found to do that (and there is probably a better way) is to use docker commands to untag the Supervisor so it doesn’t continue to restart/re-install when deleted, and then force remove all the HA containers one by one.

The first time I tried to uninstall it a while back there was also a system service that needed to be stopped and then I just removed all of the docker containers and it did stop everything from loading again.

But it just doesn’t give me a warm fuzzy that all of the things that were installed are still hanging around somewhere and never properly uninstalled. It has to install other stuff besides the system service on the OS itself outside of all the containers or they wouldn’t make such a big deal about what OS’s are supported. I guess I could dig into the script to see what is installed and decide at that point if it’s worth cleaning everything up.

It’s like trying to make sure that programs are completely uninstalled in Windows. It seems like there are always bits and pieces left behind that pop up later and bite you somehow.

1 Like

Yeah, I get where you are coming from. I found that I had to untag the supervisor container before removing it, or it automatically re-installs itself.

That, plus deleting the /config directory seemed to remove everything.

I’m not sure what that means.