Installing Home Assistant Supervised using Debian 12

Hi @kanga_who,
Thank you so much for these detailed instructions. As a Microsoft-type techie just getting into Linux and HA in my spare time they have worked perfectly for me.

Please can you help with a few things though? I’m trying to get my head around how all this hangs together. Sorry if these are basic questions, I am a newbie in all this.

Q1. In this scenario, what’s the correct way to update HA when new images become available? Does the ‘sudo apt update && sudo apt upgrade -y && sudo apt autoremove –y’ handle it all, or is there some process/situation whereby I would need to get another image from your curl place?

Q2. The various bits of HA are running in Docker runtime (I can see them all running using ‘docker stats’), so presumably there are some dockerfiles somewhere that will show me what it’s doing. Where?

Q3. I want to make a few experimental changes to a custom component. One of the changes is actually to one of its requirements, so I want to install a development version of the requirement as it says in the middle paragraph here: How do I do ‘pip install -e ./pychromecast’ and ‘hass --skip-pip’ when running HA supervised in Docker?

Your advice would be much appreciated, and thanks again!

You update HA from within HA. You do need to keep the Debian OS up to date as well, using the code your posted.

If you install the Portainer add-on, you can check each running container from a nice GUI. Be very careful though, if you edit any of the running HA containers, it is likely to stop HA from working and you may be forced to re-install.

Not something I have done, or have any experience in doing, so can’t offer advice on this.


Thanks very much, understood. I’ll post about Q3 on the development forum.

I wanted migrate from SD card to USB booted Debian on Raspbery Pi 4 , but it seems it doesn’t possible, due to limitation for default SD card booting in Rpi4. I don’t know how to change booting in hassio. Do you? I think the only option would be to get raspbian installed. Let me know if there is any better method.

See here.

Thanks for these guides which I already knew, but the problem is with booting - on hass os I can’t install eeprom or I don’t have anything like raspi-config, so I can’t change boot order. I need a spare SD card, argh.

You will need to update the eeprom first to boot from SSD, although, one of the Pi 4s I purchased already had the updated rom, so worked OOTB.

I have this installation and just got prompt that i should update supervisor for security reason. After updating in not able to access ui vi http.
In logs i see only this kind of messages:
2021-01-20 07:30:01 WARNING (MainThread) [homeassistant.loader] You are using a custom integration for reolink_dev which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant.

Im still able to connect to the host via ssh (i have open ssh there).
Im also able to connect to HA terminal addon via ssh.

In supervisor logs i have this WARNING:
Host has no rauc support. OTA updates have been disabled.

also there is this INFO:
21-01-20 07:41:44 INFO (MainThread) [supervisor.auth] Home Assistant not running, checking cache

when trying to get back to previousl snapshot getting this:
21-01-20 07:54:47 WARNING (MainThread) [] 'SnapshotManager.do_restore_full' blocked from execution, system is not running

After removing everything from config + custom components folder it was solved…

You may just need to reboot the machine after everything has updated. Sometimes that’s all it needs.

yeah reboot+remoal of recorder from config seems to do the trick…
with recorder though it is showing this in the logs and not going anywhere:
[supervisor.auth] Home Assistant not running, checking cache

Your database might be corrupted. Unless you have some need to keep it for important graphs/history, delete the home-assistant_v2.db file, and reboot.

edit: Actually, that’s probably not the issue.

When was the last time you updated the Debian OS?

i did it right after updating the HA to new version (about 2 hrs ago).
by this i mean i run :
sudo apt update && sudo apt upgrade -y && sudo apt autoremove -y

I’m wondering if you have any config that is referencing the custom_components you removed and HA is looking for that at boot.

i put them all back + updated them using hacs. So probably not?

Its just when i have recorder in config it gets stuck at that line in log.

It may be the database after all then. Try deleting as mentioned above and reboot the machine.

try a ha core check to exclude config problems, and as said before, db could be corrupt - delete it, there’s no side effects except loss of historical data.

What database are you using? If it’s not the HA default one, what URL are you parsing to recorder?

it was google cloud postgressql, now i switched to default one an everything works normally again.
Seems like a coincident - some issues in google cloud sql instance and me updating to new version.

Thanks so much for your help @kanga_who, @Tommmii, @DavidFW1960


@KangaWho how about updating the supervisor-installer script to official/latest one?
A lot of people stop here for instructions treating them as almost official. :slight_smile: