Installing Home Assistant Supervised using Debian 12

try a ha core check to exclude config problems, and as said before, db could be corrupt - delete it, there’s no side effects except loss of historical data.

What database are you using? If it’s not the HA default one, what URL are you parsing to recorder?

it was google cloud postgressql, now i switched to default one an everything works normally again.
Seems like a coincident - some issues in google cloud sql instance and me updating to new version.

Thanks so much for your help @kanga_who, @Tommmii, @DavidFW1960


@KangaWho how about updating the supervisor-installer script to official/latest one?
A lot of people stop here for instructions treating them as almost official. :slight_smile:

I forked the installer script way back when Supervised was being deprecated, and have kept it that way in the guide just in case. I do keep it updated to the official script, generally within 12-24 hours of a change being made.

Hi everybody.

I am totally newb and trying to get HA up and running on Debian, but I end up here…

How to I proceed from here?

Thank you in advance!

Unless you have raised privileges then add “sudo” to the start of the command.

Unfortunately, gives the same result…

Your command is not complete. The hardware version should also be added to the same command as per the docs.

What are you installing on?

Right, I was mistaken by this repo: :wink:

No machine type is required if on a generic PC, which this guide is for.

Have you followed all previous steps such as installing docker and the required dependencies? What machine are you using?

Hi @kanga_who

I followed the instructions from this post to install debian on my NAS as a virtual machine and then the remaining instructions to install Home assistant. added a user debian and added the user to sudoers group.

After the install, everything worked as expected until I restarted home assistant. Now Home assistant will not start.

I found this article - Autostart using systemd but I am unable to find the homeass[email protected] file at the location /etc/systemd/system

I have only one user account debian, did not create one for home assistant.


Can we use Containerd runtime instead of Docker? If so, what are the commands? thanks

Have a read of the second paragraph.

You don’t need to do this when running HA Supervised - the supervisor auto starts. If that is not happening, then I can only assume it has something to do with your VM, or the installation of all of the required containers has failed.

This guide is designed to be use on a generic PC with Debian as the OS. Being that I don’t use a NAS with a VM, I can’t really help you troubleshoot this, sorry.

thank you very much for this tutorial. it’s very clear for us newbies

1 Like

Ahhhhhhh When you spend all afternoon head bashing installing stuff per the github page, writing your own install doc, and forget this page totally exists :man_facepalming: :man_facepalming: :man_facepalming:

Thanks for the doc guys and girls.


Thank you for this guide, it really helped me out as i’m super new to this.
If i may add a couple extra things i used, in case someone needs them, I might be doing something wrong,also regarding to ADR-0014 but, that’s how it worked for me:

During the installation, i removed the Graphical Interface part, as i dont needed, and checked the SSH server installation.
Once the installation is done, i log in through ssh and apt still has the cd-rom (installed the cd-rom version through USB) as a source so i removed it:

nano /etc/apt/sources.list
#add # infront of cd rom line to comment it out

Sudo was not installed for me so had to get it:

apt update
apt install sudo
sudo usermod -aG sudo <Whatever username you are using>

And an extra step for me, i’m on a laptop and want to keep the lid closed w/o suspending the system:

sudo nano /etc/systemd/logind.conf
#uncomment the line  and change it to ignore: HandleLidSwitch=ignore
#save, exit
sudo service systemd-logind restart

And then procede to section 2 of the guide.

Hope this helps someone :slight_smile: as ignorant as me.

Has anyone had trouble with high CPU usage from avahi-daemon?

Mine kept maxing out 1 core on my NUC so I have had to disable it, don’t know if this service is needed?

I’ve tried this a few different ways and keep hitting the same wall. When the daemon.json is created and docker is stopped then it cannot be restarted. Is there a script that doesn’t create this file? There appears to be a conflict with overlay2 and zfs.