Installing Home Assistant Supervised using Debian 12

Makes sense, I’ll probably do both eventually, but will start with the addon port. Thank you for help. Definitely one of those “DURHHH” moments. Insert facepalm here.

1 Like

This is a very good question.
Trying to get my gpio/one wire sensor seen and working on my Pi4 64 is driving me bonkers. Worked fine before following this “official” supervised install guide.

Did anybody try recently installed debian-live-10.9.0-amd64-standard.iso and end up with success? I spent today a half day on trying to have a fresh installation and no luck at this time. I tried to put that Debian on USB HDD as well as on 64GB SD card (flashed by Rufus, Balena and even Rasp tool) and at every time it didn’t want to boot. On the contrary, I tested the same SD card with Raspberry Pi Imager flashing the HASS OS 5.13 from the menu and it booted immediately. Half year ago I used Debian 10.7 and it has booted installer at the first attempt. It would be strange if these two versions (10.7 vs 10.9) could differ, but any idea, why it does not boot (even from SD card) for me, I would appreciate. If you know a link to that older version of Debian I would test it as well would this work for RPI4+USB (as I had it up to yesterday)

RPi4 is an ARM architecture, not AMD64.

and last time did work for me. Need to try find the other version and test it.

1 Like

Anyone here has experience with upgrade to

docker-ce-cli/buster 5:20.10.7~3-0~debian-buster amd64 [upgradable from: 5:20.10.6~3-0~debian-buster]

docker-ce-rootless-extras/buster 5:20.10.7~3-0~debian-buster amd64 [upgradable from: 5:20.10.6~3-0~debian-buster]

docker-ce/buster 5:20.10.7~3-0~debian-buster amd64 [upgradable from: 5:20.10.6~3-0~debian-buster]

I’ll let you know…upgrading now. Note: lots of firefox security updates]

update: no problems…everything running OK including HA and pihole

Been running fine for weeks since release

Thanks for the info!!!

@kanga_who I still can’t boot Debian listed in the first post in any way, neither from USB+RPi4 nor from SD card in RPi4. I was wondering about using this version [Tested images]? would it be supported by HA then? Do you or anybody else know how this version different from the one posted in your link? HassOS, for sure, is not for me. I need Debian ! :tired_face:

When you get to the HA CLI through the addon you should be able to type “login” and then log into the host system.

I was getting:
[warn] The following is missing on the host and needs
[warn] to be installed and configured before running this script again
[error] missing: apparmor

before I found this post. Thanks!

sudo -i
before installation command

So you didn’t follow the instruction then.

Yup, this one for the RPI4 4GB is working perfectly:

1 Like

Use the Debian for Raspberry Pi guide. This guide is for Generic PC type installs.


Hi friends

First of all, thank your for this article, really good.

I have 3 doubts before starting to migrate to this installation:

1.- Can I perform this in a Synology NAS with Docker?

2.- Currently, I have a HA Docker installation in that Synology NAS, could I migrate the /config folder in order to migrate all my current configuration?

3.- Could I have watchtower to update all containers created automatically?


  1. Depending on the NAS it’s possible, but highly unlikely.

  2. No. Backup your config files.

  3. VERY, very bad idea. No.

Thanks Kanga!

I updated Debian this morning (to fix the kernel bug CVE-2021-33909, that was fixed yesterday), and now I noticed this error in the supervisor log :

WARNING (MainThread) [supervisor.bootstrap] Missing SUPERVISOR_MACHINE environment variable. Fallback to deprecated extraction!

How to fix this ? Everything is working, but still.