Installing Home Assistant Supervised using Debian 12

Worked for me. That must’ve been the root cause of my frustrations over the last few days. I could get things to work after a fresh install, but they wouldn’t survive a reboot.

Thanks again.

1 Like

Was going to post this yesterday, did 4 installs and got so pissed at the issues and finally downgraded to 5.19 as I had that on the old ubuntu and it just worked.

WARNING: The latest version of docker apparently is not compatible with Home Assistant Supervised. Suggest reading:

The fix is posted by Kanga_who above (thank you). This is posted only to add a graphic to catch people’s eye when they scan the forum instead of reading each item.

This fix is already posted 5 posts above :wink:

@kanga_who, thanks a lot, it made the trick!

1 Like

I’m reinstalling my system because of the docker issue, and decided to switch to Debian to make my installation supported.
I followed every step, but at step 4:

curl -fsSL | sh

I get stuck with the following error:

> # Executing docker install script, commit: 3d8fe77c2c46c5b7571f94b42793905e5b3e42e4
> + sh -c apt-get update -qq >/dev/null
> + sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq apt-transport-https ca-certificates curl gnupg >/dev/null
> + sh -c curl -fsSL "" | apt-key add -qq - >/dev/null
> Warning: apt-key output should not be parsed (stdout is not a terminal)
> + sh -c echo "deb [arch=amd64] buster stable" > /etc/apt/sources.list.d/docker.list
> + sh -c apt-get update -qq >/dev/null
> E: Method https has died unexpectedly!
> E: Sub-process https received a segmentation fault.

I haven’t found anything regarding this error when i search this topic, so I hope somebody can help me with this.


Hi Rick,

I’ve just fudged my way through it reinstalling 4 times thinking I had an issue with HyperV but it was the docker issue the guys have mentioned above. All is well now.

You may need the prerequisites from the Docker Debian page:

$ sudo apt-get install \
    apt-transport-https \
    ca-certificates \
    curl \
    gnupg-agent \

That might get you past that error. then follow on with Kanga’s instructions

Hello… Thank you for the installation procedure. But instead of installing on Debian 10 distribution, I used the Raspberry pi OS 64 bits (still in development but build on Debian 10 so fully compatible) to install Home Assistant supervised (I need to access the Pi via VNC to control remote equipments, easy with Raspbian OS)… It went very well (except as mentioned the docker version to downgrade to 19.03.13). Thank you again !

Unfortunately this didn’t solve the issue, still get the same error.

Raspberry Pi OS is not a supported OS by Home Assistant, you may want to check out this guide instead for installing Debian 10 on a Pi.

This guide and thread is discussing Debian 10, not Raspberry Pi OS :wink:

@kanga_who Raspberry pi OS 64 bits is based on Debian 10… So after installation, it says “supported Yes” !.. :wink:
But I understand and accept that Raspbian OS 64 bits is under development and assume all the risks associated with it but Debian 10 light is so light that it is not meeting my requirements (VNC and browser access)… Nevertheless your procedure is also working for Raspbian OS, that’s my point… So I thank you for that, you saved me time and a lot of goggle search !

same problem here today 12/12/2020.
I try to modify file sources.list…but same resoults…

Ping is ok.
I made sudo update && upgrade.
all packages are update…but can not install network manager -software utilities-app armor - jq

Before doing an apt upgrade or after the downgrade of Docker it is best to do:

apt-mark hold
apt-mark hold docker-ce-cli
apt-mark hold docker-ce

This prevents Docker from being upgraded. If in the future the supervisor has been fixed and is able to work with the 20.x version of Docker, you can undo these by:

apt-mark unhold
apt-mark unhold docker-ce-cli
apt-mark unhold docker-ce

(This information was taken from:

1 Like

Hi, Thanks for all the help. Linux an HA noob here…

I’m trying to get HomeAssistant supervised on an PC. followed the intructions and got all the way through to a working Home Assistant supervised, but when I reboot the it will not restart.

I followed the instructions here

and got it to restart, but it was Home Assistant Core(?) - not supervised.

My understanding is that the scprit should have set it up to autostart but I have tried a few times with no success. How can I get it to autostart supervised?

Myself and some others have posted this in a couple of other threads. The only issue it introduces, which you have covered off with the commands to un-do it is, people will forget what they have done and come back saying they now can’t upgrade, help, help! I’m not saying it’s a bad idea, but I can now see that it will potentially create another wave of user issues not being able to update Docker when needed.

It’s actually easier to stop OS updates for a week or so until Docker revert the changes they made and HA update the Supervisor.

1 Like

sudo apt install docker-ce=5:19.03.13~3-0~debian-buster

I did a apt update and apt upgrade then tried the steps you suggested and the file above isn’t found ???

any suggestions?

You should add the docker repository first, please see:

under the heading " Install using the repository ". After that you can follow the commands above.

Does anybody have an idea for this problem? I tried again but I can’t get past step 4.