Installing Home Assistant Supervised using Debian 12

Thanks for your helpful suggestion. Indeed, after removing the watchtower image it’s OK again, weird that HA interferes with things it shouldn’t. I could perfectly skip that container in watchtower, but instead we have to remove it completely. Sigh. I’ll try the cron instead of watchtower then ^^ Thanks again!

1 Like

Yeah that frustrated me as well. My watchtower was only managing non HA containers but just its mere presence was flagged and caused HA to be in an unsupported state. I understand that watchtower can cause a lot of issues for HA but only f it is screwing with HA containers but the blunt instrument approach is what the devs took.
I also share your disdain for Proxmox BTW. Just don’t like it and I have played with it on my dev machine.

Indeed. The “blunt instrument” approach sums it up well. It’s their right as dev’s ofc as they want to minimize the number of deviations in configurations. But IMO we’re quite capable of deciding for ourselves too and just flagging that we deviate from the recommended settings would suffice, again IMO. That’s why we containerized it in the first place, flexibility, portability ? :slight_smile:

Ow, don’t get me wrong. I’m quite the fan of Proxmox. I used it at work in production environment. Where you want complete seperation. But for this purpose it’s overkill and a waste of resources imo. Our planet has already enough to suffer :stuck_out_tongue:

I disagree. I changed my own system to Proxmox from Supervised for similar reasons your are facing. I’m not sure I would call installing an OS and then a VM an unnecessary overhead and don’t find any discernible difference in the way the machine operates verse previous, power usage is almost identical. I also changed the HA machine in my business to use Proxmox.

If you have experience in using Proxmox, I suggest you reconsider using it for HA to give you the flexibility you are looking for.

You could install in a venv, that way HA won’t be exceeding any imaginary boundaries :wink:

If you could link to where is referenced in any of the current installation instructions, that would be great. Someone can submit a PR to remove it.

Yes, the Devs have been slowly removing it from the code, it takes time as changes to that reference creates breaking changes in other places of the code, from what I have read.

Yes. Here is a great community document that details the current installation methods and names.

You will also see the current installation methods listed here on the HA website.

1 Like

Hi @kanga_who,
Thank you so much for these detailed instructions. As a Microsoft-type techie just getting into Linux and HA in my spare time they have worked perfectly for me.

Please can you help with a few things though? I’m trying to get my head around how all this hangs together. Sorry if these are basic questions, I am a newbie in all this.

Q1. In this scenario, what’s the correct way to update HA when new images become available? Does the ‘sudo apt update && sudo apt upgrade -y && sudo apt autoremove –y’ handle it all, or is there some process/situation whereby I would need to get another image from your curl place?

Q2. The various bits of HA are running in Docker runtime (I can see them all running using ‘docker stats’), so presumably there are some dockerfiles somewhere that will show me what it’s doing. Where?

Q3. I want to make a few experimental changes to a custom component. One of the changes is actually to one of its requirements, so I want to install a development version of the requirement as it says in the middle paragraph here: How do I do ‘pip install -e ./pychromecast’ and ‘hass --skip-pip’ when running HA supervised in Docker?

Your advice would be much appreciated, and thanks again!

You update HA from within HA. You do need to keep the Debian OS up to date as well, using the code your posted.

If you install the Portainer add-on, you can check each running container from a nice GUI. Be very careful though, if you edit any of the running HA containers, it is likely to stop HA from working and you may be forced to re-install.

Not something I have done, or have any experience in doing, so can’t offer advice on this.


Thanks very much, understood. I’ll post about Q3 on the development forum.

I wanted migrate from SD card to USB booted Debian on Raspbery Pi 4 , but it seems it doesn’t possible, due to limitation for default SD card booting in Rpi4. I don’t know how to change booting in hassio. Do you? I think the only option would be to get raspbian installed. Let me know if there is any better method.

See here.

Thanks for these guides which I already knew, but the problem is with booting - on hass os I can’t install eeprom or I don’t have anything like raspi-config, so I can’t change boot order. I need a spare SD card, argh.

You will need to update the eeprom first to boot from SSD, although, one of the Pi 4s I purchased already had the updated rom, so worked OOTB.

I have this installation and just got prompt that i should update supervisor for security reason. After updating in not able to access ui vi http.
In logs i see only this kind of messages:
2021-01-20 07:30:01 WARNING (MainThread) [homeassistant.loader] You are using a custom integration for reolink_dev which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant.

Im still able to connect to the host via ssh (i have open ssh there).
Im also able to connect to HA terminal addon via ssh.

In supervisor logs i have this WARNING:
Host has no rauc support. OTA updates have been disabled.

also there is this INFO:
21-01-20 07:41:44 INFO (MainThread) [supervisor.auth] Home Assistant not running, checking cache

when trying to get back to previousl snapshot getting this:
21-01-20 07:54:47 WARNING (MainThread) [] 'SnapshotManager.do_restore_full' blocked from execution, system is not running

After removing everything from config + custom components folder it was solved…

You may just need to reboot the machine after everything has updated. Sometimes that’s all it needs.

yeah reboot+remoal of recorder from config seems to do the trick…
with recorder though it is showing this in the logs and not going anywhere:
[supervisor.auth] Home Assistant not running, checking cache

Your database might be corrupted. Unless you have some need to keep it for important graphs/history, delete the home-assistant_v2.db file, and reboot.

edit: Actually, that’s probably not the issue.

When was the last time you updated the Debian OS?

i did it right after updating the HA to new version (about 2 hrs ago).
by this i mean i run :
sudo apt update && sudo apt upgrade -y && sudo apt autoremove -y

I’m wondering if you have any config that is referencing the custom_components you removed and HA is looking for that at boot.

i put them all back + updated them using hacs. So probably not?

Its just when i have recorder in config it gets stuck at that line in log.

It may be the database after all then. Try deleting as mentioned above and reboot the machine.