Installing HomeAssistant OS on desktop PC with x86-64 IMG stuck with waiting for the Home Assistant CLI to be ready

Hi all
Have an old desktop PC that I thought to install HomeAssistant OS on. I have done it using the UBUNTU USB stick method and have flashed it to an internal SSD disk. However when starting up the machine it gets stuck in “Waiting for the Home assistant CLI to be ready…” and doesnt continue from that. The image I have flashed is Anyone that can provide som e help to this? I have tried to search for this subject and have found issues with this around 2020/2021 but no real solution from the posts that I found.

What brand and model is the old desktop PC and most important of all does it support UEFI boot, but have SecureBoot disabled?

Hi its a HP Compaq CQ1000. It has UEFI and secure disabled. I guess it wouldnt boot at all otherwise

And do you have a internet connection on the machine too?

Yes, i can ping it and i can log in as root from the console. I can also access internet, ie ping

I think you just have to wait for now.
It is trying to get files from GitHub and that can at times take a while.
As long as it does not say that it failed to start the CLI, then it is still running the process.

If you run some anti-malware on the router, then be sure that GitHub is not blocked there.
There have been cases where GitHub is blocked, because hackers use it to store their attack codes.

Problem is that I have tried to wait a couple of hours and nothing happens. This is the same bahaviour that I have seen in older posts and I never found any solutions to it.

Ok, check your DNS settings then.

“nmcli con show” should show your connections.
Find your default connection and type "nmcli con edit "
Next type print ipv4 to see the configuration.
Change the DNS server by doing “set ipv4.dns” and save it with “save” and then “exit”
Finally reboot

Also when logging in as root in the console, neither ha or docker ps -a gives any resluts, the cursor just stucks so I guess something is wrong with the installation. Ive tried to install several times on different disks also but always same result

ha and docker files are downloaded from the web during the setup process, so it just means there is a problem getting files from the internet.

Will try that but why do i need to change dns to Is it some kind of bug or? I mean, I already have internet connection that is working so whats so special with this dns?

There have just been a lot of problems with DNS servers not responding correctly to requests.
Cloudflare ( and Google ( & are known good servers.

Now I have tried that to no success. When looking in the journalctl logfile it seems as if it is a problem with the mounting of disk as far as I can tell, however I have no idea why. This time I also tried the 8.5 version just to se that it wasnt something with the current version. It seems as /mnt/data does not exist?

Something fail in the installation and you need someone who really understand that process.
The last images you posted should make a good start in the hunt, but I can not help there.