Installing OpenzWave in fresh Hassbian

Hi All,

I have spent hours trying to follow other peoples help on here regarding getting OpenZWave installed and am pulling my hair out. I’m not very good with linux so everything is a battle. I’m hoping someone can point me to a thread or provide help here which is aimed at someone that doesnt know what they are doing!

My install is Hassbian (latest version downloaded this morning) on a Raspberry Pi 1B with a Razberry 1 card on it.

I can log into the Pi using Putty and WinSCP. I tried to edit the configuration.yaml in Win SCP but I got a permission error. Searching told me I need to be in user ‘hass’ or homeassistant’ (which one?) but ‘hass’ doesnt seem to exist and ‘homeassistant’ has no password yet WinSCP asks for a password when trying to connect with this user and wont accept a blank entry. Its killing me.

I must be missing EVERYTHING here because I really thought thuis would be easy after reading the installation instructions for Home Assistant but its proving to be rather difficult…

Can someone please help this idiot?



I’m prepared to be completely wrong when I say this, but…

Before you sort out all the issues you have alluded to in your post, you may find that you won’t be able to use your card with Hassbian, as it requires some drivers or whatever that are only available in the Razbian distro available from their website. What I had to do was install Razbian, switch off the services they use to start up their own interface, and then install homeassistant. Ymmv, but I thought you might want to know in advance :slight_smile:

As for the other bits you asked about…

User hass or homeassistant: In the older versions it was called hass, now it’s called homeassistant. So homeassistant is the correct one for you.

I don’t use WinSCP, but there are some threads on here where people have sussed this out. IMO it’s much better to set up a Samba share for editing files, and use putty for interacting with HA (restarting the server etc). There’s a really good video for setting up a Samba share on Bruh’s YouTube channel. If you can’t find it I’m sure somebody will provide the link (or I’ll do it later when I’m at a computer).

Hope this helps.

WinSCP works great - as long as you have it set up correctly.

Go into Site Manager (do this when you are NOT connected to your Pi) and go to the settings for your Pi connection.

Click on Advanced and then find the SCP/Shell option on the left. Select it and then make sure your settings match the ones in the image below:

Save everything and then close WInSCP and reconnect to your Pi.

1 Like

thanks guys. I had a friend help out a bit with some general Linux stuff yesterday and now I have OpenZWave installed (supposedly) but I’m not getting anything at http://pi_IP_address:8888/ so I guess something didnt go right…

After my friend sorted out some permission stuff for me I can now use WinSCP to edit the config file.

I wont know about the Razberry until I cann get into OpenZWave I guess, but I’ll take your word for it that it wont work. I’ll just have to buy a USB stick

You don’t need to change hardware, just install a different os and install homeassistant on top. Mine is working fine, just not with hassbian.

Regarding trying to access ozwcp…

You’ve stopped homeassistant, and then run the command to start ozwcp on port 8888? Do you get any errors when you try to connect?

I managed to get WinSCP sorted so I can edit the config file.

ok, I didnt try stopping home assistant. I didnt realise I needed to. I’m away at the moment so wont be able to try again until next week.

If I go down the route of installing Razbian instead, what are the services I would need to switch off, and how would I do that? Once Razbian is installed I take it that I would then just install Home Assistant via the manual method as per this link? (although it talks about being on Rasbian lite)

Thanks for the help

I think one was called Razberry and one was called Mongoose off the top of my head, and you disable them by removing the startup service.

Then yes, either manual install via that method or the AIO installer, whichever you prefer. The manual install method may be better if you are learning Linux, it’s pretty straight forward to follow that guide, but you’ll pick things up along the way you’ll use regularly when interacting with HA.

Correction, one is called Mongoose, the other is called z-way-server, they’re in the /etc/init.d/ directory, and you disable them by removing the related .conf file in /etc/init using the update-rc.d command (If I remember correctly).

z-way-server is the important one to disable as it ties up the resources of your z-wave card so HA won’t be able to use it. Mongoose you could technically leave running, but it’s useless as it is the native web interface.

(I’m also having a memory of having to disable bluetooth because of a conflict over the GPIO pins, but I don’t recallwhether that was because of this or something else, but one to bear in mind).

Hope this helps.

awesome, thanks. I will give it a try next week.

Being that I am using a RPi B (version 1) which doesn’t have Bluetooth I should be fine in that regard.

1 Like

I have managed to get Open Zwave installed. I installed the Razberry software first as per their website instructions then disabled the startups as per your comment.
The issue I see now is that Open Zwave doesnt seem to be detecting my Razberry card. I’m guessing its something to do with config somewhere but I dont know where to start… did you have any issues at this point? or have any tips?