Installing VLC on Hassbian breaks the OS

Hello all,

I wish to set up Hassbian on a Raspberry Pi at home. The installation is easy and works just fine. However, I’ve built the configuration.yaml on my local laptop and it has the vlc component installed for google Text-to-Speech scripts. When I opened the dashboard on my pi, the VLC component was not there. So I tried installing VLC multiple times (just the standard apt-get install vlc) But the installation always fails!
Not only does the installation of VLC fail, but after this failure home assistant is no longer able start and so I’ve to reinstall Hassbian.

Furthermore I’ve already broken 2 micro SD cards in the process as formatting and re-imaging the sd-card leaves it undetectable for any machine. (For this I’m using the SD-Formatter and Etcher)

Has anyone come across this issue and does anyone have a fix?

You should do ’ sudo apt update; sudo apt install vlc vlc-nox’

It will not magically appear on the dashboard! You hsve to add it in the configuration.yaml

srry for the late reply:

Thanks, I wasn’t aware of VLC-noX, I hope that one works, new SD should be delivered tomorrow.
And I am aware that it won’t magically appear :wink: As said, I’ve configured everything on a local machine, where everything including VLC works. Only after the port to HassBian. VLC no longer showed up (because it wasn’t installed yet).

If I run into anymore trouble, I’ll let you know!

I really, really, really don’t know what I’m doing wrong…
Has no one seriously experienced the same issue that has wrecked 3 SD-cards so far?
I did as you said: sudo apt update, sudo apt install vlc vlc-nox.
Same issue as installing the full VLC.

It won’t complete and fails with an error, after which homeassistant stops working and will not boot anymore.

I’ve made a screenshot of the error this time

Has anyone succesfully installed VLC on Hassbian? (rapsberry Pi model 3)
And if so, could he or she please walk me through the process?



Ok… that looks like either a corrupted cd card or an incomplete install of the OS. Have you tried downloading a new image? Also, try apt update; apt upgrade first to get the latest packages and patches installed…