Insteon Add Device w/ Address not working

I am trying to migrate a number of Insteon devices into Home Assistant, many of which are not convenient to access and press the set button. To that end, I am trying to employ the “Insteon device address (optional)” field in the UI. But whenever I put a value into this field, it doesn’t work as expected, and I see this error in the console:

2022-09-08 11:30:24.867 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection] [140268203555040] Error handling message: extra keys not allowed @ data['address']. Got '1a2b3c' (invalid_format)

To my untrained eye, this appears to be an issue with the websocket/http un-marshalling, and not an issue with the actual value in the field. I have also tried 1a.2b.3c and 1A.2B.3C, just to be sure.

Can anyone point me in the right direction to make this work? OR, are there better methods for bulk-import without going around and pushing the set buttons?

Not sure, but maybe try 1A.2B.3C which is the real address? Are you trying using the service or through the Insteon control panel?

I am using the UI (http://hass:8123/insteon/devices) and the orange “+” button for adding a device. I don’t see an equivalent service call.

When I added new devices, I went to the Hub and selected “All-Link Database” which shows me all things in my Hub. Then clicking the orange + and I see this:

Best for @teharris1 to respond but I believe that you need an entry for group 0 and group 1 likely in the Hub at least. Not sure.

I was wondering if anyone can report any progress with this issue. I have the same/similar problem with only one of 48 devices.

Logger: homeassistant.components.websocket_api.http.connection
Source: components/websocket_api/
Integration: Home Assistant WebSocket API (documentation, issues)
First occurred: 12:51:18 PM (1 occurrences)
Last logged: 12:51:18 PM

[547944854672] Error handling message: extra keys not allowed @ data[‘address’]. Got ‘3d.fa.01’ (invalid_format)

I used the set button for all the units . With this one unit HA indicates

All-Linking is complete
Device 3D.FA.01 has been added.

However neither the device or entity shows up in HA with this address.
I do see reference to it in config/insteon_devices.json

“7295”: {
“memory”: 7295,
“in_use”: true,
“controller”: true,
“high_water_mark”: false,
“bit5”: true,
“bit4”: false,
“group”: 0,
“target”: “3dfa01”,
“data1”: 1,
“data2”: 32,
“data3”: 69
“7287”: {
“memory”: 7287,
“in_use”: true,
“controller”: false,
“high_water_mark”: false,
“bit5”: true,
“bit4”: false,
“group”: 1,
“target”: “3dfa01”,
“data1”: 0,
“data2”: 0,
“data3”: 0
“address”: “3dfa01”,
“cat”: 0,
“subcat”: 0,
“firmware”: 0,
“engine_version”: 2,
“aldb_status”: 1,
“aldb”: {},
“operating_flags”: {},
“properties”: {},
“first_mem_addr”: 4095

I have an installed Insteon Device that does not respond from HA. I see that the ALDB is empty. I’ve tried
to add the device again but nothing happens. Is there a way to delete the device from HA and then reinstall? Alternatively is there a way to manually add the link to the Hub (my PLM) to the ALDB.

Sorry for the delay here. @mattc this issue should not exist and has been tested to work. Can you confirm it is still an issue? Yes, you are correct, the error you are getting is saying that the web socket is not accepting the input. The values you are entering all look correct so not sure why that would be an issue. The input should accept all of the following: “a1b2c3”, “a1.b2.c3”, “A1B2C3” or “A1.B2.B3”

I am also seeing this issue. I tried adding a device and received the following in the debug log:

2023-03-05 18:51:39.369 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection] [1846425848] Error handling message: extra keys not allowed @ data['address']. Got '41.35.22' (invalid_format) Admin from (Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36)

I see it when debugging is enabled on the Insteon integration.

I am not able to add any devices via the Insteon page add devices button. I am going to likely have to use the link button, but this is a huge headache. I wish I could specify a handful of device IDs and add them back to the modem. I had to replace my hub with a PLM so I know all the addresses, but I need to add them all.

Tag me and hopefully I’ll get an email from the community site and I can get you any more info. I am running HassIO on RPi3B 32-bit so somewhat limited on what I can test per say. Thanks for your help and all the work you put in on this integration.

Edit: Correction, I do see these messages in the home assistant log file. And I do see them every time I try to add a device with the address.

After v2023.3.2 released today the linking via inputting an address is resolved. I confirmed this does work now, and was able to add my last FanLinc device (which is awesome because the last one I did I had to take the light and blades off the fan and drop the fan partially from the ceiling to get to the fanlinc).

Thank you so much @teharris1 for all your amazing work on this integration!