Insteon Hub Conversion to Home Assistant

You can’t edit your instron schedules. What you can do though is use the newly released insteon control panel to deactivate the insteon scenes. See this post

Once you deactivate the insteon scenes, you can control all insteon devices, including scheduling on and off times, using Home Assistant automations

https://www.home-assistant.io/docs/automation/

Or, if you prefer a more visual editor, the Node red addon

1 Like

If the password doesn’t work, did you try a network settings reset? That should reset the password to what is written on the hub without needing a full factory reset.

multiple network reset attempts failed. Still can’t access using the correct port with the UN/PW from the hub label. (4 ping responses to the selected IP address were fine).

Do I need to do a factory reset? If so, what am I losing re: next steps in the automation integration?

Hello. I am also an Insteon user for about 14 years. I am trying to use Home Assistant to bring my remote use of the Insteon switches back to life. The problem is that I cannot get insteon integration to work because I cannot connect to the V1 Hub.

  1. I have a V1 hub 2242-222.
  2. I’ve purchased an Odroid-Xu4. I
  3. t has been updated with HA Core 2022.5.2 and HA OS 7.6.
  4. I’ve created an account and have successfully logged in to the OS.
  5. I try to add insteon integration and enter the IP address and Port # and it says “Failed to connect”
  6. I can ping the IP address with no issues
  7. I’ve tried going to http://IPAddress:25105 and it comes up with username and pwd box… I’ve entered the insteon username/pwd and also the default uswer/pwd for the V1 Hub admin/A1B2C3 neither work.

I have not tried a factory reset on the hub since I don’t want to lose all the scenes and info I have in there. I want to do that only as a last resort.

Any ideas on what I should do next?

Thank you!

same question as I am about at the same place as you. See above for how to do a “reset network settings” on your hub. That didn’t work for me (Tim, could that be because my router has a new wifi name and password than the Insteon hub was originally set up with? That happened after insteon went down but before by attempt to use HA), but you should try it.

My question now is like you: what do i lose if i do a factory reset?

Robert

First, do you have one of the supported devices? Per the documentation:

It is known to work with the 2413U USB and 2412S RS242 flavors of PLM and the 2448A7 USB stick. It has also been tested to work with the 2242 and 2245 Hubs

If supported, and the network settings reset didn’t work and you still can’t login, I can’t see any other alternative but a factory reset. Initially, it was thought this would brick the hub, but that was later to be found not to be the case. The documentation was updated about what to do after factory reset

You will probably lose all scenes, schedules, and need to relink all devices. Some have, some haven’t. If you lose scenes and schedules, you should recreate those as home assistant automations as mentioned above.

If the factory reset still doesn’t work, and you’ve tried this on an alternate wifi router, at that point, I would conclude the device is dead and needs replacement.

You should just use a hard wired ethernet connection. See post above if you have a supported device. Then it won’t matter what your routers wifi settings are. If the device is not near your router, you can use an ethernet powerline adapter to connect them. I’m not sure if you can still configure wifi without the insteon app/cloud.

I wouldn’t factory reset until you at least verify the device is on your network as mentioned in the posts above.

Well, this is embarassing. I did a hard reset and it failed to be found on HA. I went over to the HOOBS forum since i was about to give up on HA, and found a reference to a "mystery l " character in the password. I tried upper case i, the pipe (|) and one (1) as described in a prior post Unfortunately, i left out lower case L. This latter turning out to be the correct password.

Anyway, i now have a hard reset insteon box that works, but has no devices that i can see. There seems to be some reference to programming steps to get the Hub v2 to find devices…is there another way, like putting in the device codes (XX:XX:XX), or setting the device themselves to link modes? (this latter will be hard since some devices are controlling remote attics fans, other inaccessible sites)

Sorry to be such a techtard…on the other hand, if anyone needs to be intubated I can help :slight_smile:

Robert MD MBA FACEP

That stinks it was just an issue with the password.

You will need to relink the devices after the factory reset to add them back,

According to the documentation on the Insteion integration (below) you should be able to link new devices by calling the service insteon.add_all_link

You also might be able to use the new insteon control panel.

Ok. 2 quick techtard questions: (sorry, i can write 10 level nested “If” statements in Excel. but i have never used any programming languange.)

  1. Where do I create the instruction for the Hub to go into " insteon.add_all_link" ? I have tried to add automations and scripts (see screen shot) but both come up with error saying not allowe. I gather once successfully in the add_all_link mode, I can set each target device to LINK and the hub will find them (if done within 3 minutes).
  2. Tim: you said “You also might be able to use the new insteon control panel.” I found it in the left hand menu bar, but all it does is list the hub. Clicking on the hub and using “load from device” does nothing, I assume because I factory reset it :frowning: …so the question remains how to go into insteon add_all linking mode

Thanks to all in advance.

Robert

OK> answered my own question; found the " +" button lower right of the Insteon window of HA. adding devices manually now via sending the link from devices to the hub while HA in “listen” mode. Thanks all

1 Like

I assume you found that + in the insteon control panel.

Prior to the control panel, you would actually “call a service”. Calling a service is basically the way Home Assistant controls everything. The most common would be switch.turn_on . “Switch” being the domain, turn_on being the action. Services can be called a lot of different ways - from just clicking the device in Home Assistant main web page or an automation.

If you ever need to call a service manually, which is generally needed when you do an advanced configuration option, you would click “developer tools” on the left menu, then click “services” from the menu in blue at the top. Once you start typing in Insteon all the services available for it would start popping up, including the “add_all_link” service.

I am trying to factory reset my 2245 hub, but it doesn’t seem to work. Is a network connect back to their servers required for this to work? I never get the hub beep after the 30 second wait.

Also, will there every be the ability to delete insteon devices from the new insteon side page?

i thought the same - Insteon control panel - Share your Projects! / Lovelace & Frontend - Home Assistant Community (home-assistant.io)

…but it does reset. as best I can tell is it resets just like any device, unplug & hold the button in while plugging back in and wait for the long beep to stop

and the answer for this is Insteon control panel - Share your Projects! / Lovelace & Frontend - Home Assistant Community (home-assistant.io)

Hello,
I have Insteon Hub 2245 that was factory reset.
I was able to connect to it from Home Assistant, but I am no having any success in linking any of light switches or other devices to the HUB or HomeAssistant
I tried adding the devices via the (+) on the intsteon configuration page


When I press OK, the hub switches to the link/discovery mode (blinking green light), but when I press the set button on the light switch, nothing is added to the list.
What am I doing wrong?
Thanks!

I am by no means an expert, still working my way out of the Insteon demise fog and learning about HA.
I reset my 2245 hub to clear all the old setups, was able to setup a RasPi4 with HA and reconnected my devices (only had a dozen that were easy to access). I had no trouble using the exact process you described. The only question I might have is, did you hold the device set button until it chirped and status light blinks, can be 2-3 secs on some devices. The next HA screen should be “Device Added” with the device name, its address and an {OK} button to click. It all worked OK for me. Good luck.

Hi Robert,
Yes, I did press the set button on the device(s) (light switch) util it chirped, but no devices were added. 

Hi…Newbie here again.

I really thought I had this thing working.

I was losing the insteon hub, it seemed daily, fixable with a power off/on again reboot to the hub. The IP address is unable to be changed to static (stupid altice modem), so i put a Wemo plug on the Insteon hub and have it reboot once a day.

Using Advanced IP scanner (thank to the person who suggested that), I have confirmed that the insteon hub is connected, pingable, and at the same IP address.

However, the behavior of HA is now very bizarre. At the overview page, where i can control the individual insteon modules, they all show up correctly. However, once I turn one on, the module responds in the real world (ie pool cleaner outlet turns on), but the slider is not sticky and returns to off. (The outlet stays on in real life).

To turn the pool outlet off, I can slide the slider to on and THEN off, and the pool outlet turns off.

I have checked all the automations and (I think) i have disabled all those that call this module in any way. This behavior is not seen with non-insteon products.

Any thoughts on next troubleshooting steps? Is the wemo plug interfering somehow? (Same behavior happens with the module controlling my pool heater, which has no WEMO plug, so i doubt it).

Robert

OK insteon users. I don’t know if this is why HA has essentially crashed it’s Insteon integration on my setup, but this is good news:
THE INSTEON APP IS BACK Up AND RUNNING!!

Insteon is back from the dead, thanks to a group of customers.

6 weeks tinkering. hopefully not down the toilet, as I now have some semblance of a backup if insteon folds again.

Thanks to all who so cheerfully helped those of us stranded for the last few months!

Robert

If the app is working again, you should be able to set a static ip for your hub now. That could solve your issues.

However, I’ve seen a few posts that since the hub went back online, the Home Assistant integration became flaky. Not sure if it’s a coincidence or even deliberate by the new owners to stop customers from leaving to Home Assistant.

I would say to people happy with Home Assistant now, you might want to firewall off your insteon router from the internet so the new owners don’t potentially release a firmware to it that messes up the working Home assistant integration.