Insteon KeypadLinc Help

So my Insteon setup is working fine for my water sensors, outlets and switches. Today I started working on my Switchlinc’s and I was able to get one “seen” by Home Assistamt and the following devices were created.

switch.keypadlinc_on_off_44_47_9a_main
switch.keypadlinc_on_off_44_47_9a_button_a
switch.keypadlinc_on_off_44_47_9a_button_b
switch.keypadlinc_on_off_44_47_9a_button_c
switch.keypadlinc_on_off_44_47_9a_button_d

and if I press any of the physical buttons on the keypadlinc, the status shows up in HA, but I cannot get HA to control the buttons or the attached load which should be controlled by switch.keypadlinc_on_off_44_47_9a_main .

What am I missing?

Which integration are you using? I am using the ISY integration and they show similarly to that and respond… You probably know this already, but the “main” button is the load and will respond properly to on/off commands… The others are scene controllers. For me w/ my ISY, it means I have work to do in the ISY controller to properly setup the scene. Also, based on that config, there are ways to make it so that it will only respond to an “on” command… Just something to be aware of.

I am using the builtin HA Insteon integration. I am migrating from Homeseer and Insteon worked completely different in their implementation. I think I may have to “link” my PLM to the Keypad as it looks like I may need to have links in both directions. Although I’m not sure how to do that in HA. In Homeseer, it was just a checkbox to enable bi-directions links.

I dont know anything about HomeSeer, but if the modem/plm is the same - then you shoulnt have to re-pair. The devices are linked to modem - not the software. This page has some good info - Insteon - Home Assistant (home-assistant.io). See the pa1rt about HouseLinc or pyinsteon…

If you go to the dev tools page and try “switch.turn_on” (or off) and entity switch.keypadlinc_on_off_44_47_9a_main, does that work?

Wish I could help more…

The above did not work. I am going to try and remove and then add the keypadlinc back to HA and see if that makes a difference. I will let you know how I make out.

I do appreciate the help.

Judd

Well I got it to work. I did a factory reset on the Keypadlinc and then re-added it back to my PLM and Home Assistant is now able to control it.

Thanks again for the help.

Judd

1 Like

I use my keypad to control a fanlic. The hardware pairing is a bit of a pain to set up ( the fan has to be dropped to access the fanlinc) – the light portion of the fan. If Main On/Off buttons toggled, the light goes on and off as expected. However, if the buttons are toggled with HA, just the light in the keypad toggles - the status of the load doesn’t change. I have to change the state of the light using the light sub device of the fanlinc – Is there a slick way to get the state of the Main keypad button in HA to perform the way that it does when it’s manually toggled.