Insteon PLM Auto discovery made incorrect discovery

I am newbie probably well over my head. I am trying to convert from Indigo to Home Assistant. I am using a 2314U PLM. Struggling with the auto-discovery Process. As I understand only device linked to the PLM will be discovered. I am working with getting them relinked. I have about 24 Insteon devices. I am having an issue with the discovery process mis reading the device. In some instances a couple of lights I was to cut and copy from similar Light switches
in insteon_devices,json. Next mis-configured device I am attacking is an Insteon Lock Controller model 2862-222. The auto discover process thought it was a thermostat. Is there any one familiar with his devices or where I can find a guide to insteon_devices,json.?

Ok this i getting worse… I may manually corrected the Door Lock switch. But now it has also auto discovered my PLM as guess what… a thermostat adapter… I was going to try overwrite the configuration but where I am told to get information like

address": “49f73c”,
“cat”: 3,
“subcat”: 21,
“firmware”: 158,
“engine_version”: 3,
“aldb_status”: 1,

From the device… The back of the PLM gets me the address but now of the rest of the information… Is there any disctionary for configuration.yam;?

I am happy to help. Can you upload your insteon_devices.json file? It is in your config directory. Based on what I see, device 49.F7.3C is a PLM since it is a Cat 3 device. So if it is showing up as a thermostat it is not the discovery process

1 Like

Thanks for the response… Any help would be appreciated. See If I can work out the upload. Is their a dictionary for insteon (or any service) parameters like the Cat 3? Ok turns out that file is over 1200 lines and even the first part dealing with the PLM is over 600 but this is the first part does it help??

“address”: “49f73c”,
“cat”: 3,
“subcat”: 21,
“firmware”: 158,
“engine_version”: 3,
“aldb_status”: 1,
“aldb”: {
“8191”: {
“memory”: 8191,
“in_use”: true,
“controller”: false,
“high_water_mark”: false,
“bit5”: true,
“bit4”: false,
“group”: 1,
“target”: “1530af”,
“data1”: 0,
“data2”: 0,
“data3”: 255
},
“8183”: {
“memory”: 8183,
“in_use”: true,
“controller”: false,
“high_water_mark”: false,
“bit5”: true,
“bit4”: false,
“group”: 1,
“target”: “13ef4f”,
“data1”: 0,
“data2”: 0,
“data3”: 255
},
“8175”: {
“memory”: 8175,
“in_use”: true,
“controller”: false,
“high_water_mark”: false,
“bit5”: true,
“bit4”: false,
“group”: 1,
“target”: “13f728”,
“data1”: 0,
“data2”: 0,
“data3”: 255
},
“8167”: {
“memory”: 8167,
“in_use”: true,
“controller”: false,
“high_water_mark”: false,
“bit5”: true,
“bit4”: false,
“group”: 1,
“target”: “12faf7”,
“data1”: 0,
“data2”: 0,
“data3”: 255
},
“8159”: {
“memory”: 8159,
“in_use”: true,
“controller”: false,
“high_water_mark”: false,
“bit5”: true,
“bit4”: false,
“group”: 1,
“target”: “27eeb2”,
“data1”: 0,
“data2”: 0,
“data3”: 255
},

OK still wokring on this with (the Lock Controller). Some updated information. I am running Home Assistant OS 7.6 under a Mac Mini Host as Virtual Box Virtual Machine running Linus as a guest Currently at supervisor-2022.04.0 and core-2022.4.6. As I understand it “autodisovery” occurs. when the device is activated. I do not now how to “activate” this device. looking at insteon_devices.json. the device has been added to the data based. I can find this in the that file

“> 8143”: {
“memory”: 8143,
“in_use”: true,
“controller”: true,
“high_water_mark”: false,
“bit5”: true,
“bit4”: false,
“group”: 254,
“target”: “44a22b”,
“data1”: 15,
“data2”: 10,
“data3”: 67
},

I then try to use

“Insteon: Load all link database”.

in developer to try to get the device added… No joy. I guess I took a wrong turn… a map or directions would be appreciated

Ok. I am still tinkering with this…

I downloaded Indigo. and cycled Insteon Lock Controller model 2862-222. . and the door it controls. I turned off Indigo (server and client). and started HA. I once again used developer tools to to run the service.

“Insteon: Load all link database”.

I even cycled the controller and door lock again to see if this kicked anything off. . No success

My door locks (one z-wave and this one) are my last major (famous las words). to a usable HA system.

Any thoughts or observations?

The door lock should be pretty easy. If you go to ConfigurationDevices and ServicesInsteonConfigure, you should get an option to Add a device override. Enter the device address A1.B2.C3, for the Device Category use 0x02 and for the Device Subcategory use 0x00. This will make it show up as an On/Off switch which I am 90% sure is all you need for that device to work. There are no developer guides for the MorningStar device but I would be very surprised if it is more complex than that.

I cannot help with the Z-Wave lock other than to say I have one myself and love it but not an expert in Z-Wave at all.

By the way, you should never manually modify the insteon_devices.json file. It gets overwritten on any device change so any modifications to it are temporary. It is a caching file only in order to improve performance.

Thanks for the heads up on the Insteon file. I have the manual for the lock switch The switch is Insteon but who knows how it communicates with the morning star. The reason I was asking is that its said it was successful but it doesn’t appear in my list of insteon devices. If I go back to back to configuration i am given the option to remove. but no where else

@captcurrent Did you ever get your Insteon Lock 2862 working? I am planning to build that out into the core library soon and just want to confirm it works as a category 0x02 device as described above.

Should have listened to you the first time. Iddi the over ride again using the settings your provided instead of the ones of the actual manual. and it works fine!!! Now on to the POS Z-wave lock. Thanks!!