Insteon stops working

I’ve been using HASS.IO and my insteon for a couple of years, recently (last 3 months) with one of the updates or the hub firmware updates the two stop talking to each other. I found that I have to reboot both at least once a day to re-establish communication. I have an automation set up to reboot both at 1am (hub is plugged into a NON insteon smart plug) and communication is fine for a while, I’m currently looking at adding additional times to the reboot as it doesn’t last a full day

Anyone else have this issue? Any suggestions on how to fix it? What should I be looking for in the logs to help trouble shoot?

It works for me using insteon component version 0.16.0. Insteon hub never stop responding. see instructions below:

The fix has been posted in the latest beta release of 0.105 if you want to test it.

I would love to help test it, how do I go about that? I’ve pretty much just set up HASS.IO and configure my automatons, and really haven’t delved deeply into from there over the couple of years. Due to more lack time then anything.

That would be much appreciated. To install the beta version on follow these instructions:

Thanks installed, and scheduled reboots disabled. So far it’s working, but rebooting normally has positive results for a bit. I’ll let it run for a couple days and get back to you.

On a side note I also just swapped out my 8port switch for a 24port (higher end) switch last night. So technically I’ve made two changes at once, which I hate but here we are.

Well, if there is a problem, we can probably rule out networking :wink:

@ThisBytes5 Still good?

Worked this morning for sure, not sure about yesterday as wife got up and turned lights on with Alexa before I was up. I was also able to use HASS.IO to turn on and off lights after work yesterday and normally that doesn’t work.

Today there was a new beta, so we’ll see what tomorrow brings as well.

So far So good.

Just an update, though it seems more stable it’s not a 100%. This morning for sure the lights didn’t come on, and at least one other day. I do know the automation worked as my TV outlet came on. I’m much happier with the update.

Let me know if you need any log files, and if so where I would find them.

Logs would be good. Have you had to restart HA to get the modem to reconnect?

So far things seem to be fine without restarting, just the two times, but just started working again.

Haven’t seen an issue since the other day. Sorry I haven’t gotten the logs, life gets in the way and I also don’t know where to get them currently. Googling now for future reference.

Just another quick update, everything seems to be working fine. Lights didn’t turn on the other day, but I realized that my presence detection for ME isn’t working and my Wife was away as such no one was home. I believe this is what happened the last time it didn’t work, I just didn’t put it together until yesterday when it happened again.

If I were a QA engineer I’d sign off on the beta, and say release it!

One last question, has this been rolled into the official release? Meaning can I get off the beta and have it still work?

Yes. For future reference full releases are released about a week after the first beta. For the most part anything in the beta goes into the first release about a week later.

Thank you, off the beta now, and thanks for the work on fixing isteon plugin

I came across this thread when googling if others have been having issue with insteon after updating to HA 105.X-current or HASSIO system 3.X(as I believe there was also an update for that when the issue started). From this thread it seems like a fix for the hub had been implemented around the time I started having problems with my PLM.

I have to reboot HA every few hours-days (varies) sometimes times a reboot doesn’t fix it but a power cycle seems to always work. I’ve also tried a second PLM as I have 2 on hand with the same results. I don’t have any errors in the logs related to Insteon, but I can’t control any devices and their states don’t update if I manually change (ie physically toggle a switch).

I don’t remember which version I was on before I started having issues and haven’t tried loading any older snapshots yet. I believe my snapshot from Feb 9 is when I did the update and started having issues so what I was running may have been as old as what ever version was out on Jan 9 (date of previous snap shot-I may have done other updates w/o snap shots if I didn’t make changes to other things).

Hello all,
I have just released a beta release of an improved Insteon component. It is a major change in the backend so I am releasing it as a custom component for beta testing and really need testers and feedback. Here is the link to the details.

Just re-installed my HA, got 7 new switches installed today, had nothing but trouble with my insteon, turns out it was a bad network cable.

Once I get back to 0 (no insteon) I’ll give this a look, may be a day or two before I get there though.