Home Assistant Community

Insteon Thermostat 2441TH for ISY

#1

Just wanted to share for those interested. I am working on implementing the Insteon Thermostat via the ISY994 platform. Currently, I have read-only visibility working, but will be working to implement controls as well. For anyone that is willing to test, the code is available on the dev branch of my fork here.

Please let me know if you find any issues, and if someone has a Z-Wave Thermostat controlled by the ISY, i’d be interested to know if it works as well.

2 Likes

Insteon Thermostat Monitoring & Control through ISY-994i
Support for Thermostats connected to ISY Controller
Calling all ISY994 users!
Insteon Thermostat 2441TH
#2

awesome, looking forward to this! I’ve got a couple different types of zwave t-stat’s that i’d love to use with my ISY through the hassio integration.

0 Likes

#3

Controls for Insteon have been added (set mode, set fan mode, set temperatures). Ready for testing.

There are bugs in PyISY that needed to be fixed to enable the climate commands. You can use my develop branch fork for PyISY and manually install psuedo-version 1.1.2. I have also temporarily redirected the package to my fork in my branch of home-assistant.

@jon102034050 - Feel free to test. I have no idea if the Z-Wave T-Stats accept the same commands for control or do some of the goofy things Insteon does (like return 2xTemps to avoid decimals). I tried to keep it Z-Wave/Insteon agnostic, but let me know what you find.

1 Like

#4

It looks like most things are working from my end.

I’ll need @rmkraus to take a look at the changes to PyISY and include in an update to that module before I submit a PR to include this in an upcoming HA version to avoid creating a requirements issue.

Thermos

1 Like

#5

Hi, this looks great. I’ve been looking for this for a while. When do you think this will be released in the main release?

Do you still need people to test?
cheers

0 Likes

#6

Please feel free to test from my fork linked above. I’m currently waiting for changes made to PyIsy to be incorporated before Home Assistant will review the changes.

If you don’t want to use the whole fork, you should be able to test my changes using a custom component in the config folder… When I figure out how to do that myself I’ll post some instructions.

0 Likes

#7

Just started on Hass this week. Going to check this out! I have isy with zwave thermostat. Thanks.

0 Likes

#8

I believe I figured out the custom_component part, and now I’m ready to add the thermostat to my configuration. Could you drop a sample snippet of your configuration.yaml that invokke the thermostat?
Thanks

0 Likes

#9

Has anyone figured out how to add this to their instance? I’ve tried adding all of the files to my custom_components directory in the structure as they are from the GitHub fork, but no luck

0 Likes

#10

I have an Insteon thermostat and would be willing to test.

0 Likes

#11

TO TEST AS A CUSTOM COMPONENT:
This assumes you have ~/.homeassistant as your config directory, update as needed

  1. Copy all of the files from the isy994 component folder from my fork to ~/.homeassistant/custom_components/isy994/ (either download the whole repo zip file and copy just that folder, or download and save each file 1-by-1).
  2. Install the custom PyISY instance (still waiting for it to be updated on PyPi):
    • Run pip3 install https://github.com/shbatm/PyISY/archive/develop.zip#PyISY==1.1.2 --target ~/.homeassistant/deps --system. If you use a virtual environment, make sure you activate it first.
  3. Run Home Assistant with the --skip-pip flag to make sure it uses the custom module.
    • e.g. hass --skip-pip

EDIT: Working in Hass.io instance now too. No need to use --skip-pip, it automatically installed my version of the PyISY module in the main dependency folder. If it doesn’t work right away, check your logs and see if there was an error, I had some DNS issues with the Docker container preventing the installation the first time (couldn’t find github.com). END EDIT

Also, I had to remove the option to set “Program Auto” mode by request of the reviewers. This is not an “approved” climate mode in Hass–I completely disagree with limiting the functions that are supported by a device because they don’t match a Hass standard; if you want to weigh in on the conversation and direction the Climate module is taking: here’s your chance!

2 Likes

#12

Thanks for the instructions! This is working wonderfully.

0 Likes