Insteon - Trouble adding devices

I know a lot of folks are trying to get Insteon configured on their HA these days, but I have seen a few posts with issues trying to get Insteon devices added to this HA, but with little to no solutions. Today I tried to switch from my working ISY, to running Insteon natively on my PI setup with a USB PLM. It installed fine and I put in the path to my PLM and hoped for the best. However after the initial auto discovery process I only have 3 devices recognized. I have over 18 Insteon devices and most just weren’t added.

I tried to follow the vague (to me) description of how to use the service in the Developer Tools to manually add some of the missing devices, but without any luck. The 3 that were added, seem to be working fine, but even after restarting a couple times I still only have the same 3 devices in addition to the PLM.

Any help or direction would really be appreciated. After many many years of relying on that automations, it is confusing to the family when so many are now not working.