Integrate Aqara Hub M1S


I’m trying to integrate the Aqara Hub M1S so that I can control the Aqara B1 curtains.

I’ve ordered the following one:

The model is M1S with firmware 3.1.1.

For the installation, I’ve followed the guide provided on the integrations page and currently I’m stuck at this:

With the Mi Home App, I’m following the instructions to setup the device. But when on the page where to connect to hub’s wifi. The iPhone doesn’t want to connect to the wifi for making an HomeKit connect. See screenshot.

Even when manually connecting to the Wifi, I’m still stock the screen in the Mi Home app that says I have to connect to the device.

I’ve reset the hub with the 10 times pressing. I’ve tried to switch modes with the 2 times pressing. Nothing works.

I’m only able to add this to the Aqara app, but then Home Assistant doesn’t discover this.

What am I doing wrong? Or do I have a wrong device?

I think that this one can be integrated only with the homekit_controller integration

Will that work with the Smart Curtains?

You need to try. But cover are supported by the homekit_controller integration:

Regarding the gateway you should be able to add it to homekit on your iPhone by scanning the homekit barecode. See here:

If that works, remove it from your iPhone and pair it with the homekit_controller on HA

Hi, have you managed to implement it in a way other than through homekit?

Nope, haven’t tried the HomeKit either. Will do soon.

Hi, until now I’m not able to get this hub into HA. The Homekit-way didn’t work for me. @BartK2 or anyone else managed to achieve this?

What I know is that

10 times pressing followed by 2 times pressing this means moving from Mi Home app to Aqara app mode.


10 times pressing followed by 2 times pressing than another 2 times pressing this means moving from Aqara app to Mi Home app mode.

I have bought aqara hub m1s recently, it is a 2021 model. I can not intergrate it. How do I get it work with HA? Thanks

I have the exact same problem. M1S hub, 2021/01 model. I think I have done a reset about 40 times now. Tried every possible configuration, but it never shows in MiHome or HA, I can only get it in HomeKit or AqaraApp.

I have found the solution on reddit, and added some additional info to it.
The key is that you cannot connect with Mi Home until the voice prompt is says: “Ready to connect. Please open Mi Home app

  1. Power on and wait for 1 minute and let it finish booting.
  2. Press the button 10 TIMES QUICKLY. The blinking should stop immediately. If doesn’t then repeat the 10 clicks faster.
  3. You will hear a “Device resetting” prompt followed by LED blinking.
  4. Now press the button TWICE QUICKLY. You should hear a beeping sound and the blinking should stop immediately again. The device will restart automatically. If don’t hear the beep, then start the process again from the first point.
  5. If you hear the prompt “Ready to connect. Please open Mi Home app” then you are successfully switched to Mi Home mode. At this point it looks like it is ready connect, but it wasn’t for me.
  6. Press and hold the button for 10 seconds, until you hear the connection prompt again.
  7. Now you are ready to connect with Mi Home :slight_smile:

I can confirm, with EXTREAME difficulty it WILL integrate using the homekit controller integration, i spent over 2 hours on it and for some reason it decided to integrate while downloading a firmware update.
i dont know why it didnt do it beforehand, i followed the exact same steps over and over for 2 hours. and it just decided to integrate. i dont have an iphone, or an emulater… i just use the xiaomi home app.
when it asks for a pin code eg. xxx-xx-xxx i used the code on the hub… then it just imported the child devices.

my server is based in mainland china and i live in Australia…hope this helps.

That worked. THX

I need to say that you have to press incredibly fast not just fast the 10 times. After that I hear in the first tests no beep. Then I “play” a little bit with the button and do some ramdom double-presses. That worked. :smiley:

aqara hub m1a