Integrate HTTP Sensor to Homebridge

Tags: #<Tag:0x00007f326dd4f840>

Hey There,
so i am very new to this Homeassistant stuff but i have a smal Problem.
So i have created a few Sensors over the HTTP Sensor integration.

In Homeassistant i can see the values wich are Transmitted but now i wanted to conect them to my Homebridge Itnegration but the wont show up. I have activatet every checkbox in the settings but i cant see them. Is there any way to set the special senor Entity.

Example: entity ID: sensor.RoomTemp Integration: Sensor

Thanks :slight_smile:

In your Integrations, find your bridge and click on options:
image

In options, make sure that the sensor domain is selected and hit submit:

(and this is what I hate about the HKB integration, UNcheck things that you want exposed to HomeKit. The text on this dialog says “Choose the entities that you do NOT want to be bridged.” which, imho, is completely counter-intuitive. Anyhow, make sure that the HTTP sensors you want exposed are NOT checked and they should show up in HomeKit after you click submit again.

That didnt work The Homekit didnt shows the new Sensor.

when I go to the entities settings and click on one of the sensors it says: This entity has no unique ID, so the settings cannot be managed through the UI.

Could it be that this easy http Sensors are not suposed to show up in the Homebridge?

That doesn’t matter. You need to do this from the HomeKit Bridge integration, not the entity itself. I have dozens of sensors that have no entity id exposed to HomeKit without an issue:

For instance, all of my lights are exposed, but they have no unique entity id (Philips Wiz lights):

image

image

The trick to getting this to work is making sure the entities you want exposed to HomeKit are UNCHECKED in the integration options.