Integrating GE Concord alarm system

I’m not getting those errors, but I’m using a config file with the zones named and therefore it doesn’t need to discover the zones??

1 Like

robg is it enough to just add the entity or do you have to put something else in there to make it stop looking for other entities? Would you mind sharing your config? Thank you

Or did you just comment out discovery in general?

I’ve never noticed that error and I’ve had discovery enabled/disabled in the past.
Found it works better hardcoding the zones anyway.

max_zones = 6
euro_date_format = False

1 = Hallway
2 = Family Kitchen
3 = Formal rooms
4 = Upstairs
5 = study spare bed
6 = Bathroom Laund


for some reason I thought you meant inside HA. I have previously tried to ad a config.ini file to my concord232 folder (Run the server on a Pi 0W), but it seems like it was ignored.
Did you have to do anything to make it use the config.ini?

No it’s outside of HA. BUT I realised I’m talking about the NX584E alarm interface, believe they are very similar if not the same.

I wrote some instructions here on how fto hook into the NX584E:

But in answer to your question, yes need to add it to your command line ie:
ExecStart=/usr/local/bin/nx584_server --config /home/pi/alarmpanel.ini --serial /dev/ttyUSB0 --baud 9600

See how you go, but it definetely does work…for the 584E anyway. Keep me posted!

Thanks Robert. I won’t be able to mess with it until the end of the week, but I will definitely report back when I do
I remember looking into it a little bit when I initially set it up, but nothing is mentioned about the config option in the documentation for concord232, so since I couldn’t get it to work I figured they had disabled that part.
On a side note. Have you played with the email portion of that config? Is it possible to set it up for a secure smtp like google?

Hi Robg,

The concord232 project doesn’t use the config file like the pynx584 project does. It is set up to accept the --config arg, but never uses it for anything as far as I can tell.
Not really positive either that this would solve the error in homeassistant either,

Bummer! Maybe not related but I don’t get those errors.
maybe put in a request to add this config file feature??

I’m pretty sure the problem we are seeing, stems from the way the client class Concord232Alarm(alarm.AlarmControlPanel) is implemented/updated in
It looks to be quite different than how pynx584 is implemented.

Was trying to figure out what was causing these errors in the log too.

Looks like HA is constantly trying to discover the panel sensors and doesn’t acknowledge when it’s found them.

Would defining them in the binary sensor section individually and turning off discovery resolve this.

Might be worth a try.

Hi all, thinking about attempting this as well.

Want to monitor my Concord4 zones as sensors in HA. Originally I was going to attach them all to X10 addresses at the panel and then listen for X10 events on open. Not a perfect state-sensor but would at least give me open events. Well my add-on (and many other’s attempts) is not working yet, so I’m considering other options.

Seems like this is fighting you guys as well.

Are the sensors working but you are getting the errors a lot or is this constant discovery giving you duplicates that interfere with status and automations?

All sensors are working fine here. The PIRs are setup in such a way that battery life is conserved. Don’t want them constantly tripping and wasting battery life.

As soon as the panel is armed they will notify immediately of any movement in the zone.

The open/close sensors are perfect for automation. They will advise the system immediately when open or closed.

The binary sensor platform handles all the discovery of devices.Yes for some reason is constantly rediscovering the devices but it does not affect the operation between HA and the panel.

Thanks for the info!

Are you guys able to DISARM your Alarm without entering a code? I just realized I don’t need to ad a code to disarm the system. I could’ve sworn I had to do that earlier.

May be a misconfiguration on my alarm panel, but hopefully somebody can help.
I can pretty much use ANY code in xxxx and my system will disarm. Same goes for HA disarming

concord232_client disarm --master XXXX

If I disarm at the panel I have to use the correct code. Does a separate code has to be programmed for the Superbus 2000 RS232 Module? I browsed the menu, but couldn’t find any options for that.

Yes. Home and Away arm/disarm without a code.

Are you using the default code of 1234 that came with your panel. Check the code. As far as I remember 1234 is already preconfigured in the body of the code so whatever is entered on the Hass numeric keypad is ignored.

The code came precoded with 0520, but I’m pretty sure thats just a placeholder. I can put any code in there and I’m still able to unlock my system via superbus module without using a code.