Integrating GE Concord alarm system


#62

OK,

for some reason I thought you meant inside HA. I have previously tried to ad a config.ini file to my concord232 folder (Run the server on a Pi 0W), but it seems like it was ignored.
Did you have to do anything to make it use the config.ini?


#63

No it’s outside of HA. BUT I realised I’m talking about the NX584E alarm interface, believe they are very similar if not the same.

I wrote some instructions here on how fto hook into the NX584E:

But in answer to your question, yes need to add it to your command line ie:
ExecStart=/usr/local/bin/nx584_server --config /home/pi/alarmpanel.ini --serial /dev/ttyUSB0 --baud 9600

See how you go, but it definetely does work…for the 584E anyway. Keep me posted!


#64

Thanks Robert. I won’t be able to mess with it until the end of the week, but I will definitely report back when I do
I remember looking into it a little bit when I initially set it up, but nothing is mentioned about the config option in the documentation for concord232, so since I couldn’t get it to work I figured they had disabled that part.
On a side note. Have you played with the email portion of that config? Is it possible to set it up for a secure smtp like google?


#65

Hi Robg,

The concord232 project doesn’t use the config file like the pynx584 project does. It is set up to accept the --config arg, but never uses it for anything as far as I can tell.
Not really positive either that this would solve the error in homeassistant either,


#66

Bummer! Maybe not related but I don’t get those errors.
maybe put in a request to add this config file feature??


#67

I’m pretty sure the problem we are seeing, stems from the way the client class Concord232Alarm(alarm.AlarmControlPanel) is implemented/updated in


It looks to be quite different than how pynx584 is implemented.


#68

Was trying to figure out what was causing these errors in the log too.

Looks like HA is constantly trying to discover the panel sensors and doesn’t acknowledge when it’s found them.

Would defining them in the binary sensor section individually and turning off discovery resolve this.


#69

Might be worth a try.


#70

Hi all, thinking about attempting this as well.

Want to monitor my Concord4 zones as sensors in HA. Originally I was going to attach them all to X10 addresses at the panel and then listen for X10 events on open. Not a perfect state-sensor but would at least give me open events. Well my add-on (and many other’s attempts) is not working yet, so I’m considering other options.

Seems like this is fighting you guys as well.

Are the sensors working but you are getting the errors a lot or is this constant discovery giving you duplicates that interfere with status and automations?


#71

All sensors are working fine here. The PIRs are setup in such a way that battery life is conserved. Don’t want them constantly tripping and wasting battery life.

As soon as the panel is armed they will notify immediately of any movement in the zone.

The open/close sensors are perfect for automation. They will advise the system immediately when open or closed.

The binary sensor platform handles all the discovery of devices.Yes for some reason Concord.py is constantly rediscovering the devices but it does not affect the operation between HA and the panel.


#72

Thanks for the info!


#73

Are you guys able to DISARM your Alarm without entering a code? I just realized I don’t need to ad a code to disarm the system. I could’ve sworn I had to do that earlier.


#74

May be a misconfiguration on my alarm panel, but hopefully somebody can help.
I can pretty much use ANY code in xxxx and my system will disarm. Same goes for HA disarming

concord232_client disarm --master XXXX

If I disarm at the panel I have to use the correct code. Does a separate code has to be programmed for the Superbus 2000 RS232 Module? I browsed the menu, but couldn’t find any options for that.


#75

Yes. Home and Away arm/disarm without a code.


#76

Are you using the default code of 1234 that came with your panel. Check the Concord.py code. As far as I remember 1234 is already preconfigured in the body of the code so whatever is entered on the Hass numeric keypad is ignored.


#77

The code came precoded with 0520, but I’m pretty sure thats just a placeholder. I can put any code in there and I’m still able to unlock my system via superbus module without using a code.


#78

Could you try 8 1234 at the panel numeric keypad. Does it drop you into programming mode.


#79

Nope. And neither does 8 0520 which is hardcoded in mine. I tried to change the hardcoded number and that doesn’t change anything either. Like I said I think its just a placeholder. It looks like key presses should be passed, but for some reason any combination works.

Do you have to enter the correct code to disarm or not?


#80

No I mentioned that in an earlier post.

The two codes your system should have are the master code and the installer code. Which one of those codes do you use on the panel numeric keypad.


#81

So if you don’t have to input a code, your system doesn’t work as intended either. I use the master code on my panel.