Integration for SmartLink WiFi (SpaNET)

It is needed the integration of the SmartLink WiFi that it is used also by SpaNET to control and operate a spa pool.

There are some developments that regards this, but for OpenHab.
OpenHAB - Spa pool automation for SPANET SPALINK pool controller

Oh man I need this

Yes … I need this , too ! It would be nice to control the spa with automation etc.

Yes and Same, need this as well.

Yes, this would be grat!

Hai, I have been playing around with this a bit and given the smartlink can connect to Alexa I installed alexa media player and created a script to adjust the spa temperature for a test and it worked! I am 6 months in working with home assistant and have no background in this stuff (builder here) but pretty sure there would be a way to get temperature updates, turn on pumps, lights etc with the same method. A work around while an integration gets implemented I guess.

Here is the script I used;

alias: Test ALEXA
sequence:

  • service: media_player.play_media
    data:
    media_content_id: alexa open MySpaPool and then set the temperature to 37’C
    media_content_type: custom
    target:
    entity_id: media_player.julian_s_echo_dot
    mode: single

Apologies, I do not know how to format the code correctly

If anyone has the V3 Spalink it now supports MQTT. Works a treat.

Can you elaborate on how to use mqtt with the v3 version? Thanks

Hi Ibsailn

You need to have the latest firmware on your V3 module and have the latest version of the mobile app.

Then under settings in the mobile app for the spa, you will see a place to enter the credentials for your MQTT broker.

After that, all the entities should appear in HA.

Cheers

Hey,
I have the latest firmware and can see the option to add MQTT, however when I add my server IP, user and password it keeps saying “MQTT not configured”.

I am using the mosquito add on and integration in Home Assistant.

Edit: Disregard I got it to work finally. The server name needs to be: mqtt://[Ip address]:port

My home assistant mqtt lists the server as “core-mosquitto” and port 1883. Username is homeassistant and password is a long string.

I can’t get the spanet app to connect though. I have tried mqtt://10.0.0.151:1883 as well as mqtt://core-mosquitto:1883 with and without the mqqt://

Any ideas what I am doing wrong? Do I need to use external fixed IP address?

I ended up having to create a new user and used that for mqtt broker… Then it worked, but I only get 6 entities, and spanet status is the only one remotely useful. Can I use the mqtt to control temp or such settings?

Yes. It may depend on your version of controller however. I am able to control everything including temperature, lights, pumps and modes.

When I enquired with Smartlink they sent me the attached file. It may help.





Thats nice. Does anyone know how to trigger the software update on the Spanet controller? I see in the API that my Controller has an update available

payload.information.systemInformation.firmwareUpdateAvailable: true

but I have no idea how to trigger that.

Received a guide from SpaNET Support on how to perform the update. Worked like a charm.

1 Like

Following this. I have V2 wifi module so no MQTT for me.

V2 allows remote operation with the SmartLink App so it should be possible to use the same API for Home Assistant also, at least in theory…

Do you need to do something on the spa control panel to put it in firmware update mode first? Looks like it scans for bluetooth devices.

Yeah I can’t work this out.

If I hold [Blower]-[Clean]-[Light] on the spa control pane I get into a service info menu. It shows:

  • Software Version V6 21 04 2021
  • Type SV3

Which is the same as what the app shows. I think I need a newer firmware version to get the MQTT setting in the app though? (v3.1?)

When I try the firmware update as above (log out from the app) it scans for bluetooth devices but the spa doesn’t show up. I think I need to press some key combo on the panel to get it to do this? (Have a gave feeling I had to do this before when they changed the app).