Integration Honeywell T6 WiFi - site does not accept password?

Hi all,

I’m in need for some mental support, and perhaps even a solution to my problem :slight_smile: I’m well-versed in IT, but not coding, so Home Assistant is sometimes an enigma to me.

I’ve been running HA succesfully on my Raspberry Pi 4B (32bit, and EOL next year, will be a project over the summer to move to arm64) in a Docker setup.

Kernel: Linux unificontroller 5.10.103-v7l+ #1529 SMP Tue Mar 8 12:24:00 GMT 2022 armv7l GNU/Linux
OS Version: Raspbian GNU/Linux 10 (buster)
IP address: 192.168.100.90/24

This machine has the hostname unificontroller as that was the primary intended function, but seeing the performance of it, I kept adding other stuff (also in docker).

The OS has all updates applied, apt has nothing new for it.

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Running Adguard Home and Caddy I’m providing the following destinations on the machine, as well as just the containers throught the IP:Port fashion.

uptime.home
agh.home
unifi.home
dokuwiki.home
assistant.home
pfsense.home
netdata.home

The docker image I use is home-assistant/raspberrypi4-homeassistant:stable Docker
The version of HA I’m running is

Home Assistant 2023.5.2
Frontend 20230503.3 - latest

The docker run script I use:

#!/usr/bin/env bash

IP=$(ip -4 addr show eth0 | grep -oP '(?<=inet\s)\d+(\.\d+){3}')
DOCKERTAG='stable'

docker run -d \
  --name homeassistant \
  --privileged \
  --restart=unless-stopped \
  -e TZ='Europe/Amsterdam' \
  -p ${IP}:8123:8123 \
  -v /mnt/raid5/homeassistant/config:/config \
  --net=bridge \
  ghcr.io/home-assistant/raspberrypi4-homeassistant:${DOCKERTAG}

Now for the situation at hand.

I’ve replaced a pretty bad Remeha thermostat (bad software, poor temperature management) with a Honeywell T6, Y6H810WF1005, over WiFi, not Zigbee. Since I already have my P1/DSMR gateway installed and data for my energy consumption (electricity and gas) and generation (solar panels) showing on the Energy dashboard, I would also like to show the temperature reported by the thermostat.

I have an account on https://developer.honeywellhome.com/user/me/apps where I created my API key.
I have an account for Resideo (Honeywell was acquired, or had a merger?) to use my app on Android to set up the thermostat.

Different email addresses (sub-addressing used), different passwords.

Supposedly this should work like a charm as the device supports HomeKit, but I’ve tried it a few times now and I keep getting stuck at the same spot.

When I try to add the integration using the documentation Honeywell Lyric - Home Assistant I do the following:

Menu Settings → Devices & Services → Integrations → “Add Integration”

Here I type honey, click the “Honeywell” button, and chose “Honeywell Lyric”.

In the pop-up I enter a custom name, the ID and secret which I created on the developer website.

A new page opens with this URL (this might be omitting steps because I fiddled around with it before, no idea how to reset that):

https://api.honeywell.com/oauth2/authorize?response_type=code&client_id=[[bla]]&redirect_uri=https://my.home-assistant.io/redirect/oauth&state=[[bla]]

(client_id and state is redacted, for privacy and clarity reasons)

with the following body:

{
  "code": 400,
  "message": "The redirect URL provided does not match the redirect URL registered for the app."
}

Following the docs, if I replace the redirect_uri to

https://api.honeywell.com/oauth2/authorize?response_type=code&client_id=[[bla]]&redirect_uri=http://192.168.100.90:8123/auth/external/callback&state=[[bla]]

I get the same error.

If I replace it with

https://api.honeywell.com/oauth2/authorize?response_type=code&client_id=[[bla]]&redirect_uri=http://assistant.home:8123/auth/lyric/callback&state=[[bla]]

(I suppose the IP address would work here as well, figured that I might as well use the DNS name)

I get a nice Resideo login screen, but it doesn’t accept my credentials!?

Sorry, we cannot find a user with these credentials.

Searching on Google gets me a lot of hits, with github repos, plugins, additional containers, etc, but I think most if not all of that has been obsolete since HomeKit was incorporated in HA core?

I would very much like to know what I need to fill out where? :slight_smile:

Thank you for your time! :slight_smile:

I don’t have this thermostat personally, but my sister does and I set up home assistant at her house for her. Being the home assistant lover that I am I always try and find the way in which I can control it locally. In the case of the Ecobee 3 Lite and the T6 Wifi I found that integrating it into home assistant through homekit to be the way to go since homekit locally interfaces with connected devices and isn’t reliant on cloud for getting information from the thermostat as far as I can tell.

1 Like

I would be very much interested in that. Not even controlling it, just reading metrics.

How would I go about achieving that? I don’t have any Apple devices, nor Alexa, nor Google assistant in my home

It may be a bit different for you since you are running home assistant on docker on RPI, I generally have HassOS set up, I believe it is Home Assistant OS now. But when I have set up the thermostats I mentioned it generally just popped up as a discovered device.

You don’t have to have an apple device or anything. I believe in your case you probably will want to investigate the homekit controller integration. When you add it, the integration will search your network for unpaired homekit devices after which point you should be able to select it then I believe it will ask for a pairing code that will pop up on the thermostat and then you’ll be able to control and see the metrics related to your thermostat.

1 Like

Cheers, I’ll look into that and report back :+1:

In they meanwhile, if anyone has further ideas, keep’em coming :wink:

Right, so had to change a couple things.

  1. Thermostat was on a IoT/Guest WiFi, where entities have isolated settings (ie. network members can only access the internet, not each other)
  2. Docker container was running with a bridged network, changed this to --net=host \

After clearing and rebuilding the container, startup took a while longer than usual and I got the pop up for newly discovered devices, my heart jumped! :wink:

However, “only” Volumio and Kodi showed up, no thermostat yet. No discovered devices from within the container either.

pi@bla:~/ $ docker exec -ti homeassistant bash
bla:/config# python -m netdisco
Discovered devices:
Discovered 0 devices

However, after I did the “Settings” → “Rset Homekit” on the thermostat, it almost immediately showed up! This is the way :slight_smile:

From there the adoption was a breeze and I managed to get a card on the default dashboard, showing the current temp and all possible operations:


Now, what I would like to have though is a historical graph on the Energy dashboard, to correlate gas consumption with the ambient temperature and the operational mode of the thermostat (ie. what is/was the temperature, and am/was I heating or not?).

Is that even possible, given that the Energy dash doesn’t have a 3-dot menu to edit? Would I have to clone it somehow (if so, how) or rebuild it (how?) maybe?

1 Like

A climate entity in this case doesn’t compute energy consumption or have something in the energy dashboard since typically thermostats don’t have an energy monitoring device in them. If you do look at the historical graph for the entity, mine can be seen below, you will see when the system is running in my case here you can see the heat turn on in the mornings for a brief period the red bars that go to the bottom of the graph.

So many thanks for sticking with me although the initial question was answered :slight_smile:

Agreed! The reason I’d like that in Energy is that the heating of the house is like 90% of the gas consumption which is there as well, not because it uses energy itself. I would like to see in a bat of an eye if gas consumption was due to the heating turning on or not? It’s an enrichment indeed.

:slight_smile:

If that’s not possible, c’est la vie, then I’ll open 2 tabs, all good!

thanks!! this is great solution