Integration new sensor Homematic HmIP-STE2-PCB

hello, I use the Homematic IP sensor HmIP-STE2-PCB, which allows “temp differences” - for now I only see the battery status - no temperatures.

THX in advance …

Uwe

Support for that device was introduced with pyhomematic 0.1.72, which has been released 18 days ago. So after the most recent release of Home Assitant. Hence you have to wait for the next release.

1 Like

Hi, got the same problem, but allthough a New release came out a few days ago there is still just the battery status shown, no temperatures…

1 Like

It should work I guess. But since I don’t have the device I could never test it myself. Let’s see what others have to say.

Not work till now, only the battery as described. THx.

Could you please try if adding "TempModuleSTE2", to this list solves the issue?

Allthough it is an HomematicIP Cloud Device? I tried adding “TempModuleSTE2” to your mentioned list, but nothing changed.

1 Like

At no point in this thread it was clarified if the HomeMatic or the Homematic IP cloud integration is being used. My statement is valid for the first option (which makes use of a CCU or Raspberrymatic). If this thread is about the cloud-integration, then ignore my statements. :+1:

Except for the topic because the device says HmIP. Don’t know if it even works in the homematic environment. Any guess for HmIP? Thanks for your help so far!!

The component is used in the Cloud environment (as specified and works fine in the homematicIP-App.

Of course, the regular HomeMatic integration supports HmIP deivces perfectly fine. That’s why I have reacted to this topic. Most of the HomeMatic users are using this integration. Only users who are using the HomeMatic IP Access Point have to use the cloud integration. But I’m not involved with that one. Hence it appears my suggestion for the fix is irrelevant in context of this thread.

Anyways thanks for your help. But then the thread should not be marked as solved so that it is up to date again, right?

1 Like

That’s correct. :+1:

1 Like

coreGreenberet added the device to the library 15 days ago.Does this mean, that we just have to wait until our home assistant build updates or do I have to put the new library manualy into the customcomponents folder? If so, how do I do that?
Any help would be appreciated!!

Any Ideas?

Doesnt work till now