Integration not found:

Hi i have make changes on my configuration file added 3 files and im get this error:

Integration not found: scripts
Integration not found: shell
Integration not found: input

The problem is that i have already created in the homeassistant folder the scripts.yaml,shell.yaml and input.yaml that already have correct lines of code but still get this error.

Look the configuration file automation:

automation: !include_dir_merge_list automations/
group: !include groups.yaml
scripts: !include scripts.yaml
switch: !include switch.yaml
input: !include input.yaml
shell: !include shell.yaml

can you share the content of one of your files (scripts, shell etc)?
There’s always a chance there’s an indentation issue…

of course

Looks like you’re new to this. it’s definitely indentation issues and formatting.
Indentations are crucial in yaml, try services like to check your code

If you use a single file (input: !include scripts.yaml), don’t start with an indentation.
also check the docs, there are plenty of examples to get you started.
For example, there is no such component as input
Select the component you want to use from

For your scripts
your block starts with an indentation, shift your block so it start at position 0
name: is not a valid option
you’re missing an indentation after sequence:
check for examples of how to build your script

Feel free to have a browse at my config to see how I’ve used !include

Good luck and have fun, it’ll become easier, don’t worry :slight_smile:


There is no scripts component, it is script.

There is no shell component, it is shell_command.

There is no input component, there are input_boolean, input_number and several others.

You need to go right back to the basics of homeassistant configuration in the documentation.


Thank you very much for help!
Ιn few minutes i fixed the indentations issues , i thought that was same with php or other language that can include your own libraries.
Anyway im new in yaml and because of poor English i having understanding problems,

That i want to do for now as a train test is to make a script that turns of the pc after two seconds,
if i success ill proceed to another scenario to enable pc (i already did the wake up button and works) at 02:00 and turn of at 06:10 every day.
I already make on scripts.yaml that calls a - service shell.command.turn_off_chris the turn of chris is shell.command declared on the shell.yaml i dont know i im doing something wrong but i dont know how to call that thing i dont know even if that three yaml communicate.
also i try to make a second switch button that run a command_off but doenst work…
You can see my confiquration

look at this to backup your config to github without exposing things that should snot be public.

Your github has a copy of your db and secrets.yaml which should not be exposed…
Once you have your script setup, you just need to call it to test:

I already did this but doesnt work
on service data i put the { “entity_id”: “script.turn_off”}
but doesnt work.
That entity_id is on scripts.yaml on my confiquration

you shouldn’t need to enter { “entity_id”: “script.turn_off”}, all you need to do is select script.turn_on from the first drop down menu then select script.turn_off on the 2nd
The next thing is, I don’t want to sound patronising but you really need to spend more time looking at the docs.
Your script will not work:

- turn_off
  alias: turnoff
  - delay:
      seconds: 2
  - service: shell.command.turn_off_chris <-- this should be shell_command.turn_off_chris (with an underscore)
        entity_id: script.turn_off <-- this is not valid for shell_command

shell_command command does not take parameters, and even if it did, it would not take reference to a script. If somehow your code worked, you’d enter an infinite loop as you seem to be calling your script from itself

1 Like