Integration uHoo airsensor

Hi

Anyone integrated a uHoo recently with success?
I found a link which requires business account with uHoo

This one uses the normal consumer API and works great. My server just died and I have to reinstall everything because I’m the idiot without a backup - so need to re-learn how to install it myself!

Ah yes, it should be installed via HACS

Thanks - don’t have HACS, but I’ll try it out.
I’ll get back once tried.

Hi @andrewleech
HACS installed and running - installed your integration - restarted.
But I guess that I need to enter my credentials for my uhoo account somewhere?
Nothing shows up (named uHoo) under devices or entities?

Can you provide a few pointers - thx?

Hi @andrewleech

Really appreciate if you have time to point me in the right direction, thx…

Hi, sorry I missed your last message. It’s not actually my integration, I just use it myself.

Once the repo is added in HACS, you need to install the module itself. For this you go to the standard HA Configuration → Integrations page and hit “ADD INTEGRATION” button. You should be able to search uHoo there now (hacs adds it to the list).

When you install that, it should popup a page to put in uHoo official user and password. For me that login page is missing the field labels, but it’s username at the top and password in the middle. There was also a checkbox, I don’t remember what it’s for but I left it as default.

After updating to core-2021.6.0, this intergation no longer loads (or is visible in the “integrations list, after the repo is installed”)

anyone have a fix?

:sweat_smile: Sorry, I was a bad developer. Version 0.0.3 should fix the issue that was breaking on core-2021.6.0. There’s also some improvements like supporting the HA device registry and tests.

Hi, is this integration still being maintained? Im trying it out but can’t login using known good credentials?

If you look at the GitHub, it appears it is no longer working. Seems like the company changed the authentication link.

hello. I have integrated my UHOO very recently (less than 1 week) and I get all numbers.
But the think is that it does not “refresh” datas. I need to restart to get updated numbers.
I tried the following script, but does not work:

uhoo:
    email: xxxxx
    password: xxxx
    sensors: temperature, humidity, air pressure, pm 2.5, carbon dioxide, carbon dioxide, pm 2.5, nitrogen dioxide, ozone, organics compounds
    force_update: [temperature, humidity, air pressure, pm 2.5, carbon dioxide, carbon dioxide, pm 2.5, nitrogen dioxide, ozone, organics compounds]
    scan_interval: '00:01:00'
    mode: local
    reload: always

after restart:

and after a couple of minutes io loose all datas:

1 Like

Were you able to get this fixed?

Hi dv8, well did not work. Do you have same device ?

This is what happens to my setup as well. It works at first, but then becomes unavailable after a few minutes.