Integration with Broadlink TC2 and Broadlink Hub with Raspberry Pi

Tags: #<Tag:0x00007f73988be710>

Hi Experts,

I have Raspberry pi 3 configure with broadlink RM Pro (Hub). I installed broadlink TC2 switch panel to control my light and fan but i cant seems to get the on/off command from broadlink “learn_command”. I get this error below:

17-01-03 19:41:20 homeassistant.components.switch.broadlink: Did not received any signal.

Any of you guys manage to make it work?

Many thanks in advance.

There are some bugs in the latest release.
That should be fixed by this version: https://github.com/home-assistant/home-assistant/pull/5065/files

Edit: I now see that you use TC2, witch version of HA are you using?

Hi Daniel,

My HA version is 0.35.2 will try to use the update file.

Will update you guys again.

Thanks.

Happy New Year…

Hi Daniel,

I get the same error: 17-01-03 22:30:09 homeassistant.components.switch.broadlink: Did not received any signal.

:frowning:

Getting this error below from the log:

17-01-03 22:48:28 homeassistant.core: Error doing job: Task exception was never retrieved
Traceback (most recent call last):
File “/usr/lib/python3.4/asyncio/tasks.py”, line 233, in _step
result = coro.throw(exc)
File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/core.py”, line 1049, in _event_to_service_call
yield from service_handler.func(service_call)
File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/switch/broadlink.py”, line 89, in _learn_command
check_data)
File “/usr/lib/python3.4/asyncio/futures.py”, line 388, in iter
yield self # This tells Task to wait for completion.
File “/usr/lib/python3.4/asyncio/tasks.py”, line 286, in _wakeup
value = future.result()
File “/usr/lib/python3.4/asyncio/futures.py”, line 277, in result
raise self._exception
File “/usr/lib/python3.4/concurrent/futures/thread.py”, line 54, in run
result = self.fn(*self.args, **self.kwargs)
File “/home/homeassistant/.homeassistant/deps/broadlink/init.py”, line 440, in check_data
response = self.send_packet(0x6a, packet)
File “/home/homeassistant/.homeassistant/deps/broadlink/init.py”, line 250, in send_packet
response = self.cs.recvfrom(1024)
socket.timeout: timed out

Try to increase the timeout in the config.

Hi Daniel,

increasing the timeout did not help still getting the same error. :frowning:

It might be something wrong with your network.

Is TC2 already supported?

Hi Daniel,

Does the home assistant only learn IR commands? How bout RF command?

Thanks.

with the RMPRO it can learn both IR and RF. Some patience is needed though: many times it does not get teh code or is wrong, I don’t know why this intermittent behaviour

Hi Claudio,

Yeah with IR seems to work perfectly fine. But RF seems keeps getting timeout or No signal received. I guess just have to keep on trying.

:frowning:

I had success and failures with both IR and RF.

In my experience probably more failures with IR

Oh… My IR were stable which learning command could managed to capture IR code but not in RF. :frowning:
I’m happy enough that there’s a lot of people who are willing to help one of those will be Daniel.

Hoping to get TC2 working. TC2 with Alexa voice command it working fine.

How you make TC2 work with Alexa?

I think your problem is not about RF learning… is about TC2 connection!!!
Have you tried another RF remote learning?

TC2 is not supported yet.

TC2 can not be learned by RM-PRO because they do not send RF signals when manualy pressed…
they work like SP sockets… they talk to e-control by wi-fi.

Hi Claudio,

I use the android rm plugin.

is TC2 has WIFI built it? i thought TC2 is using RF for control. anyone has TC2 and e-control app can confirm if the switch state is feedback to the e-control if we on/off the TC2 switch manually?

Ahh yes. Try also the RM Tasker program. Very cool, I stopped using it because it all works with HASS now (for RMPRO), alhough will use again for the TC2 (ordered them), until they are also supported natively by HA

I really hope so. I bought them thinkinbg they had this functionality