Integrations unavailable after Docker install

I feel like a total noob here, but I’ll ask anyway.

I’ve installed HomeAssistant in Docker using the official container:

docker pull homeassistant/home-assistant

I followed the docs and everything is up and running on port 8123. Some integrations have been auto-discovered, some other are missing.

One example of integrations that have not been auto-discovered is the Bluesound integration, that appears to be available here:

It’s nowhere to be found when I search for it in the Lovelace UI:

I can not find a way to add this integration so that my Bluesound devices show up – what am I missing?

I’ve tried editing configuration.yaml, both with discovery: and by manually specifying my players IP addresses, as specified in the integration documentation.

I thought that my Docker installation only came with a selection of integrations, and Bluesound might not be the most popular one, so it may require some manual installation. To check it I logged into my Docker container, and it appears that bluesound does exist there, among other components:

$ docker exec -it home-assistant bash
# Now inside container
$ ls /usr/src/homeassistant/homeassistant/components | grep blue

Seriously, I must be overseeing something, please help me out.

Have you restarted Home Assistant? You need to restart after making changes to configuration.yaml to load the new configuration.

Absolutely, everytime. Tried both via the UI and restarting the Docker container.

I also updated to the just recently (5h ago) released version on Docker hub. Still no Bluesound or Verisure integrations (mentioning that other one just so you’ll know it doesn’t appear to be an issue with one integration only).

Not all integrations can be added via the Integration UI menu In your case you need to add the config to your configuration.yaml as mentioned in the page for that integration

Once you have done that and retsarted HA, open up developer tools, select the states tab and then search to see if its listed there

Well, I managed to get them to show up and even added to the Dashbord, so it looks like a property of type media_player.

But there are still some issues. It shows up as some kind of read-only entity.

But when I want to see some settings, it complains about missing unique ID:

I tried to set a unique ID (enity_id) here, but my attempts seem to have no effect.
Any idea on what this read only mode means? Why doesn’t it show up as e.g. the Chromecast media player entity?

(I wasn’t allow to post more than 1 screenshot. :confused: )