Intel NUC and Aeotec Z Stick 7 not detecting devices

I’m running Hass OS on an intel nuc directly. Not in a container or anything and have recently purchased an Aeotec Z Stick 7. I used to run all my z-wave devices using a vera hub and the add on but i want to keep it all in one now.

I updated the firmware on the z stick as mentioned in the home assistant manual and all went well. Plugged it into my Nuc, installed z-wave JS add on and integration. The device was detected, created all the security keys etc but every time i go to add a device it just doesn’t detect anything. I’ve tried adding these devices to my old Vera Z wave hub and it pairs up fine so it’s not the device i’m adding.

Any ideas why this could be happening? I read on another forum that there can be some interference with the z stick being so close to the nuc so i bought a USB extension and its at least half a metre away from the nuc but still not help.

I’ve attached a copy of the log from when i try and add a device if this will help.

                                    · IsFailedNode (0x62)
                                    · ReplaceFailedNode (0x63)
                                    · undefined (0x65)
                                    · GetRoutingInfo (0x80)
                                    · UNKNOWN_FUNC_LOCK_ROUTE_RESPONSE (0x90)
                                    · UNKNOWN_FUNC_GET_PRIORITY_ROUTE (0x92)
                                    · UNKNOWN_FUNC_SET_PRIORITY_ROUTE (0x93)
                                    · UNKNOWN_FUNC_UNKNOWN_0x98 (0x98)
                                    · FUNC_ID_SERIAL_API_SLAVE_NODE_INFO (0xa0)
                                    · FUNC_ID_ZW_SEND_SLAVE_NODE_INFO (0xa2)
                                    · FUNC_ID_ZW_SET_SLAVE_LEARN_MODE (0xa4)
                                    · FUNC_ID_ZW_GET_VIRTUAL_NODES (0xa5)
                                    · FUNC_ID_ZW_IS_VIRTUAL_NODE (0xa6)
                                    · BridgeApplicationCommand (0xa8)
                                    · SendDataBridge (0xa9)
                                    · SendDataMulticastBridge (0xab)
                                    · UNKNOWN_FUNC_GET_LIBRARY_TYPE (0xbd)
                                    · UNKNOWN_FUNC_SEND_TEST_FRAME (0xbe)
                                    · UNKNOWN_FUNC_GET_PROTOCOL_STATUS (0xbf)
                                    · UNKNOWN_FUNC_UNKNOWN_0xD2 (0xd2)
                                    · UNKNOWN_FUNC_UNKNOWN_0xD3 (0xd3)
                                    · UNKNOWN_FUNC_UNKNOWN_0xD4 (0xd4)
                                    · undefined (0xd6)
                                    · undefined (0xd7)
                                    · undefined (0xd8)
                                    · undefined (0xd9)
                                    · undefined (0xda)
                                    · undefined (0xdb)
                                    · undefined (0xdc)
                                    · undefined (0xdd)
                                    · undefined (0xde)
                                    · undefined (0xdf)
                                    · undefined (0xe7)
                                    · undefined (0xe8)
2023-01-30T23:03:04.807Z CNTRLR   Performing soft reset...
2023-01-30T23:03:04.820Z CNTRLR   Waiting for the controller to reconnect...
2023-01-30T23:03:06.051Z CNTRLR   reconnected and restarted
2023-01-30T23:03:06.061Z CNTRLR   querying version info...
2023-01-30T23:03:06.078Z CNTRLR   received version info:
                                    controller type: Bridge Controller
                                    library version: Z-Wave 7.18
2023-01-30T23:03:06.078Z CNTRLR   querying protocol version info...
2023-01-30T23:03:06.103Z CNTRLR   received protocol version info:
                                    protocol type:             Z-Wave
                                    protocol version:          7.18.1
                                    appl. framework build no.: 273
2023-01-30T23:03:06.104Z CNTRLR   supported Z-Wave features: 
                                    · SmartStart
2023-01-30T23:03:06.104Z CNTRLR   querying controller capabilities...
2023-01-30T23:03:06.124Z CNTRLR   received controller capabilities:
                                    controller role:      primary
                                    is the SUC:           true
                                    started this network: true
                                    SIS is present:       true
                                    was real primary:     true
2023-01-30T23:03:06.124Z CNTRLR   querying serial API setup capabilities...
2023-01-30T23:03:06.142Z CNTRLR   supported serial API setup commands:
                                  · GetSupportedCommands
                                  · SetTxStatusReport
                                  · unknown (0x03)
                                  · SetPowerlevel
                                  · unknown (0x05)
                                  · GetPowerlevel
                                  · GetMaximumPayloadSize
                                  · GetLRMaximumPayloadSize
                                  · unknown (0x12)
                                  · unknown (0x13)
                                  · GetRFRegion
                                  · SetRFRegion
                                  · SetNodeIDType
2023-01-30T23:03:06.143Z CNTRLR   Enabling TX status report...
2023-01-30T23:03:06.160Z CNTRLR   Enabling TX status report successful...
2023-01-30T23:03:06.160Z CNTRLR   Querying configured RF region...
2023-01-30T23:03:06.178Z CNTRLR   The controller is using RF region USA
2023-01-30T23:03:06.178Z CNTRLR   finding SUC...
2023-01-30T23:03:06.194Z CNTRLR   This is the SUC
2023-01-30T23:03:06.194Z CNTRLR   querying additional controller information...
2023-01-30T23:03:06.212Z CNTRLR   received additional controller information:
                                    Z-Wave API version:         9 (legacy)
                                    Z-Wave chip type:           EFR32ZG14 / ZGM130S
                                    node type                   Controller
                                    controller role:            primary
                                    controller is the SIS:      true
                                    controller supports timers: false
                                    nodes in the network:       1
2023-01-30T23:03:06.238Z CNTRLR   [Node 001] Embedded device config loaded
2023-01-30T23:03:06.251Z CNTRLR   Interview completed
Starting server on
2023-01-30T23:03:06.271Z CNTRLR   [Node 001] The node is alive.
2023-01-30T23:03:06.271Z CNTRLR   [Node 001] The node is ready to be used
2023-01-30T23:03:06.272Z CNTRLR   All nodes are ready to be used
ZwaveJS server listening on
New client
New client
Client disconnected
Code 1000: 
2023-01-30T23:33:25.879Z CNTRLR   Starting inclusion process with strategy Default...
2023-01-30T23:33:25.919Z CNTRLR   The controller is now ready to add nodes
2023-01-30T23:34:56.356Z CNTRLR   stopping inclusion process...
2023-01-30T23:34:56.389Z CNTRLR   The inclusion process was stopped

Here is also my device settings

Appreciate any help i can get.

1 Like

I’ve also tried using the Z-Wave JS UI add-on and i have the same issues. It detects the z-stick, goes into pairing mode but doesn’t find the device. Even tried all the different security/encryption options with no luck still.

Log attached.

2023-02-02 13:15:33.305 INFO APP: GET /api/auth-enabled 304 3.255 ms - -
2023-02-02 13:15:43.208 INFO Z-WAVE: Calling api startInclusion with args: [ 0, { forceSecurity: false, name: '', location: '' }, [length]: 2 ]
2023-02-02T02:15:43.211Z CNTRLR Starting inclusion process with strategy Default...
2023-02-02T02:15:43.250Z CNTRLR The controller is now ready to add nodes
2023-02-02 13:15:43.251 INFO Z-WAVE: Controller status: Secure inclusion started
2023-02-02 13:15:43.252 INFO Z-WAVE: Success zwave api call startInclusion true
2023-02-02T02:16:13.210Z CNTRLR stopping inclusion process...
2023-02-02T02:16:13.251Z CNTRLR The inclusion process was stopped
2023-02-02 13:16:13.253 INFO Z-WAVE: Controller status: Inclusion stopped

Are you excluding the devices first so they are removed from the Vera?

Yeah excluded them from the Vera. Even tried it again last night just to double check its not the devices im trying to pair. Paired them up to the vera no problems and un paired no problems.

Tried just clicking un pair on Home Assistant as well to see if it would trigger anything but nope.

Your profile says you’re in Australia, but the region of the controller is programmed to US. You need to change the region if your devices are from the AU region, they aren’t compatible.


Oh man!! That totally makes sense. Need to get home now to change it!

If you don’t mind me asking what tells you the region?

Wait… just read it in the logs. So obvious!!

Region is logged on startup.

Amazing!! This worked. Thank you so much.

Devices paired up instantly.

1 Like

Hi Adam,

I am trying to install one of these Aeotec Z-Stick 7. I am running AU frequency for Z-Wave. Just wondering if the frequency is changeable on the stick?

Hi Reesion,

Yes, using the Z-Wave JS add on you can change the region by selecting your stick in the device list and simply changing the region to your required region in the pulled down menu.

1 Like

Hi akkaria,

Where do you see the option to set the region?

I have the same problem (US region, AU devices) but I don’t see where I can set the region?

Device page. Can’t attach 2 photos in 1 post

Setting region and power levels of a controller is only available with Z-Wave JS UI.

1 Like

You need to download the Zwave JS Addon in order to change the region. I believe that’s the only way it can be done through Home Assistant.

1 Like

Thanks! Managed to get it to work