Intel NUC bluetooth?

how can I enable bluetooth on my NUC? I would like to send command to my bluetooth wall motion mount using NodeRed.

Thank you.

Nobody said its not possible so far… so… I still have a chance that somebody encounter and resolve this problem… Right?

Did you get an answer on this? I’m having the same issue. Bluetooth works on the NUC for me (keyboard, mouse, etc.), but can’t get HA to pull any devices.

nope :frowning:

I just tried to get this running this weekend and couldn’t get it to work with HassIO. I don’t think it allows for anything but Broadcom chips. My NUC doesn’t have on board BT, I have a Linux compatible dongle.

How are you running HassIO? Mine is in a Docker, so the host OS and my other containers can access the Bluetooth device. Node-Red can see it and I just pass that to HA

I am running just hassio alone with addons (Mosquitto, Influxdb, Grafana, Nodered, AutoSSH, SSH, Samba, mariaDB). My Nodered do not see BT at all as well. As you alreday said, there is support just for Broadcom chips on RaPi so far. I did create ‘Request Feature’ post but it seems like nobody care :-/

I am wondering… if I stick some USB BT dongle with BCM43xx Bluetooth chipset into NUC, would it work? But I am not sure if such dongles even exists…

me too …, I have a spare pi3, so will use that one, although would prefer a solution for the NUC

@anon35356645 I have deoployed my RPi for BT puropses as well, but it just doesn’t ‘feel right’ when NUC could do it itselves :confused:

Agreed, manage hass on the NUC is already very time consuming, not want an additional machine to look after

Has anyone had any luck with Bluetooth on a NUC, especially in a Docker environment?
I have tried the internal bluetooth adapter with no luck, I have also tried a Parani UD100-G03 dongle. With the dongle I was able to get some level of success but for a very short period of time and it seems like the dongle loosed connection within 15 min to the 2 or 3 hour range. Any help would be appreciated.

Yeah. I don’t run hassio, but bluetooth passes through from my NUC to my Docker containers just fine.

I don’t have either, I just realized that it was in the category after I posted.
Can you assist answering these questions?

  • Are you using the integrated bluetooth adapter? If not, what are you using?
  • what /tty is your bluetooth connected to if applicable.
  • Any other bluetooth drivers you had to install? Did you have to do any device pairing?
  • Or did it work straight out of the box?


Bluetooth is a network adapter. You don’t have to pass any bind mounts through. Just use net=host and it will show up. Just enable Bluetooth device tracker and it will work.

For what it’s worth - I thought I’d pass on my NUC bluetooth success here.

I’m using Hassio (Intel_Nuc image as provided here -

I disabled the NUC bluetooth in the bios and plugged in a Targus Bluetooth 4.0 Dual Mode Micro USB Adaptor Model No ACB75A. I was able to use it as a Bluetooth Tracker straight away as per this - Literally plug and play (one reboot).

Wondering if anyone has managed to get a Flic Server or some integration with Tile Pro going with bluetooth on a NUC?

Hello, use this tutorial, it works on NUC and rpi

Regarding this topic, has anyone succesfully integrated motionmount?


1 Like

Hello I am controlling Vogel’s MotionMount via NodeRed running RPi.

  • hassio switch sends mqtt message
  • NodeRed will receive it and will run gatttol command which move my mount.

Dear Mike, could you please share the mqqt message and maybe a quick how to in node red ,to get things going. Right now i am not using node red, just plain yaml scripts and automations.

Thank you

mqtt message is there just to trigger NodeRed exec node which run gatttool command so it can be anything you like. More important is gatttool command arguments:
sudo gatttool -i hci0 -b XX:XX:XX:XX:XX:XX --char-write-req -a yyyyyy -n zzzzzz

XX - Mount’s MAC address
yyyyyy can be:
0x0012 for back and forth movements
0x0015 for left and right movements
0x0056 for combination of movements

zzzzzz can be:
for 0x0012 - from 0000 to 0064 (from wall to full extend)
for 0x0015 - from 0000 to 0064 (from wall to full left) or from 0000 to ff9c (from wall to full right)
for 0x0056 - combination of all e.g. 0064ff9c (full extend and full right)

So my typical watching position is:
sudo gatttool -i hci0 -b XX:XX:XX:XX:XX:XX --char-write-req -a 0x0056 -n 0062ffbf

Here is a nice tutorial for HA + NodeRed:

Good Luck! :slight_smile:

1 Like

Hi, this does not work on NUC, when you type in bluetoothctl you get command not found…