Intelligent Home Components

I’ve recently started using the Home Assistant via Hasbian on my RPi3. Since learning about it, I’ve spent a ton of time learning how it works and how to set it up. Currently I don’t have many home automation items to utilize the Home Assistant just yet.

I have a few items that I used when I had Time Warner/Intelligent Home for home security. My understanding is that these use ZigBee to communicate. I was thinking of getting something like that controls both zwave and zigbee.

I guess my question is, if I get a USB stick that supports Zigbee radios, what are the chances I can get my old Intelligent Home items working? Is this possible? I assume the answer is “No”. I’ve read some where I may need some Time Warner tech code to use the same channel?

I have:
SMC Networks Door/Window sensors: SMCDW02-Z (3x)
Centralite HA Thermostat 3156105 (1x)
PEQ 0YW91500RQ5 Indoor/Outdoor Camera (1x)
SMC SMCGB01-Z or SMC SMCGB02-Z Glass Break Sensor (1x)

So far I’ve been able to get the Camera working. The camera is the iCam 1000.

For anyone else that may need to get this camera working:
1. I purchased a this POE cable, and connected my iCamera to my router. In order to provide power and connect to the network wirelessly or via ethernet, you need a cable similar to this one.

2. Once The camera is connected via ethernet to the router, and power from the wall outlet, I was able to power up the camera, and view the IP address from the router. Mine ended up being 192.168.1.130.

3. I opened up a new browser window, and typed in the IP address. This brought me to the iCamera login page. The default login is administrator with no password.

4. I wanted wireless support, so I went to the wireless tab, and clicked Site Survey. I found my SSID in the list, and entered that in the SSID field, along with my wireless password under Shared Key. Click Save.
NOTE: I also changed my username and password for the camera at this point under Maintenance. Once you save these settings you will be prompted to log back into the camera settings. Enter your new username and password here.

5. I unplugged my camera from the router, and used the POE cable which came with the camera to provide power only. After 1-3 minutes, I was able to access the camera settings from the 192.168.1.130 via wifi.

6. I added the camera to my home assistant config via Samba in my configuration.yaml file.

camera:

  • platform: mjpeg
    name: iCam
    mjpeg_url: http://[username]:[password]@[ip address]/img/mjpeg.cgi

7. I saved my configuration file, and rebooted my rasberry pi via the terminal window with sudo reboot.

EDIT: I’ve also been able to use the ffmpeg platform as follows:

camera:

  • platform: ffmpeg
    name: iCam2
    input: rtsp://@[ID_ADDRESS]:[PORT]/img/media.sav
  • The port is under the Network Tab in the Network Camera Settings labeled as RTSP Port.
  • If youd like to add security checking, go to the Video Access tab and select “Enable Security Checking”. You can either create users or use the admin username and password. The input in your configuration.yaml for ffmpeg will then look like this:

rtsp://[USERNAME]:[PASSWORD]@[ID_ADDRESS]:[PORT]/img/media.sav

1 Like

I’ve also purchased the HUSBZB-1 to attempt to connect the thermostat and sensors I had from Intelligent home. I’ve gotten the home assistant to recognize my adapter my adding this to my config file:

zha:
usb_path: /dev/ttyUSB1
database_path: /home/homeassistant/.homeassistant/zigbee.db

In the terminal, this is what is showing for the usb stick.

[email protected]:~ $ ls -al /dev/ttyUSB*
crw-rw---- 1 root dialout 188, 0 Sep 17 10:05 /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 1 Sep 17 10:05 /dev/ttyUSB1

This is as far as I’ve gotten. My attempts to pair the door sensor so far have not worked. I found this in instructions on Amazon to pair it to the Intelligent home touch screen:

You will need to make sure that your battery is in and the sensor is next to the magnet before you begin. Once in the >pairing mode (under add sensor) move the sensor away from the magnet and this should pair it with the touchscreen. If >that fails keep trying, it is easier to do this with it right next to the touch screen so pair it before you install it in the final >resting location.

I have a brand new battery. I followed these steps while calling the zha permit service in the developer tools. After rebooting the pi I do not see any new devices. I’m not sure if this device wont pair, or if I’m doing something wrong. Any help is appreciated.

Hi Haven8,
I also have the Time Warner obsolete security package: icamera-1000, motion sensors, door sensor and glass break sensor.

I tried to follow your posts for the camera but I can’t get HA to recognize it…could you help me out. -thank you and much appreciated