Interesting touch switch lanbon l8

Has anyone been successful in using the Dimmer function?
I have a Lanbon l8 Dimmer switch and I’ve flashed 0.60 and since 0.61 onto the device.
Everything seems to have gone smooth and I do see 3 entities in HA (Moodlight, Backlight and Dimmer) but only Moonlight and Backlight appear to be functional.
Dimmer on the other hand does not appear to be functioning. I’ve tried most the various Pin Type definition for GPIO12 but I don’t see any change (no light can be toggled and obviously no dimming then)
What is the correct Pin Type for GPIO12 (I got the US dimmer version)?

By the version numbers it looks like you have installed openHASP firmware on the device.

The GPIO configuration should look like this:

I don’t have a US version, so you might need to select L8-HD (AU) instead of the EU version. Be sure to restart the plate after making changes.

If the dimmer in the base still fails to respond, it is best to power cycle the whole device by cutting the 120V AC for ~30 sec. The dimmer in the base is initialized by the ESP32 at boot-up. If it received too much garbage because of the incorrect GPIO configuration, it might need a reset.

I used this basic pages.jsonl for local control:

{"page":1,"comment":"---------- Page 1 ----------"}
{"obj":"label","id":8,"x":5,"y":5,"w":230,"h":30,"text":"Kitchen Dimmer"}


In HA it looks like this and the controls are working fine:

L8-HD (AU) and a 30 second reset did the trick.

Thank you.

1 Like

If I have here a Lanbon L8 marked ‘HomeKit’ for the firmware on both switch front and the wall part can I successfully flash that for openHasp ? The sellers details say not HA compatible but that I hope means it’s just not yet got openHasp firmware within.

Yes you can.

1 Like

I don’t know if this is the right place, but I just wanted to let everyone know that there is a new version pcb with dreaded tuya support. The module I have still has an ESP32 on board, and that the tuya module is only connected with RST, VCC, GND, TXD1 and RXD1 to the pcb.
I will check the connections of the ESP32 to see if they are the same, but I already know that it still is controlling the TS, LCD, Relays and RGB LED’s.

1 Like

Thanks for the new revision! That’s actually a big bummer for people that care about privacy, security and want to run their own independent firmware…

I hope the chip doesn’t perform any critical functions and can be removed or disconnected…

Since only power, reset, RX and TX are connected I am quite hopeful that it can be ignored unless there is a problem with the ESP32 modules they used…

Pin 16 (TXD1) of the tuya CB3S module is connected to IO13 of the ESP32
Pin 15 (RXD1) of the tuya CB3S module is connected to IO2 of the ESP32

I first tried ordering a Landon L8-HS from one AliExpress seller, who messaged me that there would be a delay because there were some problems with the units and that it would take a few weeks to get stock. :worried:
So I ordered from another seller and got a Landon L8 with a sticker over the model name(s) that has the tuya logo and a modified model name: L8-HS-TY (or L8-HSU-TY). :hushed:
I haven’t been able to connect it to my network with the original firmware strangely enough (although it can create an AP and can scan and see all the wireless networks) and now I am not sure if I want to send it back or take the gamble and just flash openhasp on it. :thinking:

PS Dank je voor je werk aan openHASP

It seems bizarre to put two wifi chips in the same device?

I was contacted by lanbon directly 3 months ago offering this new switch. Early this year I purchased 30 “original” switches directly from them via alibaba and they had my details. I asked if they would continue offering/supporting the direct mqtt version and they said yes.

This is the email. [email protected]

Worth asking them directly, but to order via alibaba min qty is 5 units.

Maybe (I’m not sure) this has something to do with tuya support and a proprietary chip that is there as a tuya requirement?

Maybe this is just a wrong shipment and they have versions with and without tuya? But it seems weird to me to have 2 different pcb’s (with and without tuya support) while they only have to remove the tuya module for the “normal” version.

I found out that it uses the FT6336 (V or U?) Touch controller, so it can’t use the pre-compiled firmware for the Landon L8, because that uses the FT5206 controller.

I am willing to compile my own firmware IF I can find out if the LCD controller is the same and which pins it uses for SPI communication. Problem is that I really don’t have a clue what the pins on the LCD ribbon are, any help figuring out controller and Pinout is appreciated :sweat_smile:

The touch controller should both be compatible with the openHASP build. They only differ slightly in features and we use the same driver for both chips.

It would be strange if they changed the pins on the LCD, so my bet would be to just try the current Lanbon L8 build. To be sure, backup the original firmware first :).

That is good to know!
I thought they would be different because the wiki has “ -D TOUCH_DRIVER=5206” defined for compilation, but I just looked at the configuration on GitHub and they have “ -D TOUCH_DRIVER=6336”. I first want to try and see what the tuya and ESP32 module are gossiping about, I will definitely make a backup first before trying openhasp.

I also want to add that if you want to flash/program the ESP32 via the exposed connector, you can only power the ESP32 with the 5v input, not the 3.3v.

The Landon L8 uses two well known 1117 linear regulators to go from 5v to 3.3v.

  • One for the ESP32 (and in my case the tuya module) and moodlights.
  • One for the touchscreen controller and the LCD+Backlight.

The 3.3v connection on the exposed pin header is the one that powers the display only.

Flashed openhasp en it is working :slight_smile:

1 Like

I’m glad to hear openHASP is working on the Tuya version… that’s a big relief!

Thanks for pointing this out, the wiki indeed needs an update :slight_smile:

Good to know, I’ll add that to the documentation too.

wow what an abomination. they just jammed in a tuya module to have connection to their cloud. probably because tuya doesn’t have a ready made solution for ESP32 chips or they completely ditched Espressif.

I just desoldered the Tuya module and completely removed it, and it is still working normally.
I didn’t want the extra energy usage (how minimal it might be). I am a bit worried that in the future the ESP32 might be omitted completely.

Well done.

But tik tok? God preserve us from this nonsense.