Intermatic PE653RC Pool Controller and HA

Reaching out to the HA community for some help/guidance.

I currently have an Intermatic Z-Wave based pool controller (the PE653RC is the base and the PE953 is the handheld controller). I have been looking across the internet for help on adding this system to my HA setup. There was an active thread on this on the Smartthings community forum however I migrated off of Smartthings months ago and have been extremely happy with HA. My entire house is a mix of Zigbee and WiFi devices and runs great and I would love to add my pool control to HA. My Zigbee devices are connected thru my Nortek HUSBZB-1 radio/hub which also handles Z-Wave so I should be able to connect to the base but so far I have not found any info that anyone has a successful setup working.

Any help/feedback on this topic would be very much appreciated.

Thanks in adavance!

Didn’t know Zwave controller existed but will check it out

Look in zwavejs device database(will edit this later and post link) and see if it’s there. If not it will be necessary to get manual and work to add it.

Few functions are supported by zwavejs
I’m sure more can be added but someone would need to test and add them and devs likely don’t have device to do it. It’s not hard just time consuming and hit/miss

Unless this control variable pump it is functionally a bunch of relays turning things ON and OFF on schedules or in sync

It may be easier to buy Zwave relays or make WiFi relay using ESP and control through HA.

Thanks, I will take a look at the link you shared.

Any luck getting the multiwave up and running? That is the only device I really lean on day to day and hesitant to move off of Vera to HA.

No, I pushed this to the back burner on my end. I look at it about every 2-3 weeks but so far that is all. As I have no other Z-Wave devices in my network it has been slow getting started.

I looked at the Smarthings community a week or so ago. I came from the Smarthings world when I moved to HA and there was an active discussion on pulling this into ST. I also saw some discussions on a Hubitat forum. Looking for inspiration :slightly_smiling_face:!

I really would like to pull this into HA someday.

I have a special ROM from Intermatic that might help. I will go and dig it up. It would mean you need to flash your Multiwave with it. I think it is version 3.9? Thats what I used for Vera to pick it up and it works great.

Thanks, I appreciate any help/input.

A positive update. I have been able to pull the PE653 into HA, using Z-Wave JS. I tried to also add the PE953 as a secondary controller but the two controllers did not play well together. To add the PE653 to HA I had to remove the PE653 from the PE953 Z-Wave network and then perform the the Add Device in the Z-Wave JS integration in HA. It pulled in all 5 switches, the air temperature (no sensor connected) but not the water temperature sensor.

I am now creating control flows in Node-Red (I use Node-Red for all my automations) and a control panel dashboard. I am doing all of this on a standalone instance of HA running on a Raspberry Pi. Once I have everything working the way I want I will then implement this on my main HA instance which runs on an X86 mini PC. Below is how the PE653 shows in the integration. The red text is how the switches came over. I named the entities to make it easier for me to remember the functions.

I have moved this over to my main HA instance. After doing so, I spent time creating automations in node-red and a dashboard for interacting with my automations. Below is the primary view:

and this is the view when I select the Spa

as it only makes sense to show the Blower option when the Spa is operating.

I have put the PE953 on the shelf in the garage. As my wife and I always have our phones with us when we are by the pool this is an easier way to interact. I also have the dashboard displayed on my wall mounted tablet that I use for managing the house functions.

This has been a fun learning experience and adds the last remaining “automatic device” to my Home Assistant. Now I need to automate some of our dumb appliances (water heater, washer & dryer, etc).

I dont use the PE953 either but I need the Temperature sensor to work since I control my pool heater from the Vera use the fireman switch control. It works just like a thermostat control.

For me it isn’t an issue. My heat pump provides the temperature control for both pool and spa modes. Switch 5 in my Intermatic 653 switches the temperature set point - when the switch is off (open) it regulates at the pool temp and when on (closed) it regulates at the spa temp. The set points are stored in the heat pump.

I was surprised with the ease I had with pulling the 653 into the Zwave JS integration. I have spent more time creating the dashboard. Fortunately, I no longer need to replace batteries in the 953.

So here’s what I know about the Intermatic PE653 / PE953. I’ve had it running on Home Assistant using OpenZWave and now with zwave-js but there are some significant quirks. And some firmware versions are just kinda broken altogether.

I wrote my own firmware updater since I couldn’t get the Intermatic software to run anymore for some reason.

What I know about firmware versions:

  • v3.3: Works fine. The relays are represented as 5 binary switches and must be polled to observe state changes. The thermostat setpoint is represented with type 7 (furnace) which confuses the algorithm that zwave-js uses to determine the correct type, so it is not discovered and the temperature can’t be changed in Home Assistant.
  • v3.4: Quite broken. The relays can’t be controlled or polled by zwave-js (the request times out). The thermostat still isn’t discovered correctly.
  • v3.7: I wasn’t able to get it to include in the network when I last tried a few years ago.

Here’s how to pair the device on v3.3, should be similar for v3.4:

  • Reset receiver
    • Press and hold P/S & ENTER on remote
    • Press include button on receiver
  • Reset receiver
    • Press and hold P/S & ENTER on remote
  • Include receiver
    • Press button on Z-Stick
    • Press include button on relay
  • Include remote
    • Press and hold P/S & ENTER
    • Press button on Z-Stick
  • Associate remote to receiver
    • Plug Z-Stick into power supply
    • Press include button on receiver

I was planning to add some compatibility shims to support the thermostat but first I decided to upgrade my firmware from v3.3 to v3.4 to match what’s currently being shipped to customers but v3.4 seems even more broken!

At this point I’d really like to know if anyone is successfully running v3.4 firmware together with zwave-js. I’m inclined to revert to v3.3 and just fix the thermostat issue.

I’ve opened an issue to track compatibility improvements for these devices in zwave-js.

My firmware is 3.1. everything works as I describe above and explicit polling is not required - state changes automatically report in HA.

So far I am very happy with my setup, other than no reported water temperature. I will likely add a separate sensor so that I can monitor this as the heat pump has its own temperature control, with independent pool and spa setpoints. Switch 5 on the PE653 is used as a dry contact the selects which setpoint the controller uses.

PS - in reading everything I could find on the intermatic I don’t plan to update my firmware. Read multiple stories of people having issues with the upgrade process.

I am running v3.9 firmware that Intermatic installed for me several years ago. It provides access to pretty much everything that the system can do, including variable speed pump control, setting variable speed settings, all 5 switches, and more. I had it running great on my ISY, but am converting all z-wave over to Home Assistant on zwavejs MQTT. Unfortunately, much of the settings are not yet supported by the drivers for zwavejs. Biggest issue right now is that the thermostat settings for controlling my heater only work for pool mode, not for the Spa. The way zwave sees the heater control is that Pool mode is Heat function, Spa is Cool function. Both are heat, of course, but zwave sees it as a normal thermostat with heating and cooling. Heating works the heater for Pool mode, and cooling works the heater for Spa mode.

But for now, it only allows me to set Pool mode heat set point, which is useless to me. I only use the heater for my spa.

I am trying to get the PE653 working better. I have found that there is a great configuration file created for SmartThings in the “groovy” file format.

Is there any way to convert this into the json format needed for zwavejs, so that it can be imported and used with Home Assistant?

I pulled the same file and looked at it before I took the plunge. This accommodates all the various types of installations and setups. In the end, I chose to do a specific flow in Node-Red tailored for my installation setup.

All 5 controls from the 653 show as individual switches in the ZWaveJS integration which I then control via my Node-Red flow. My heater has individual Pool and Spa temperature settings and switch 5 from the 653 is a dry contact that controls the mode.

It has been trouble free since I did this and I am very pleased. I have a separate tab in my Lovelace dashboard for monitoring and controlling the pool.

How did you get both Pool (which is heat) and Spa (which is cool) to show up? All I get is the Thermostat Setpoint called HEAT, which controls heating when in POOL mode. I cannot get anything that sets thermostat setpoint for SPA. Thanks!

I have a Rheem heat pump pool heater. The controller for this heater has the option for both settings built in, as well as a water temperature sensor. The heating set-point is controlled by a dry contact input with the actual thermostat control built into the heater. I did have to manually set the Pool and Spa set-points at the heater but these are stored in the heat pump controller so that was a 1 time deal.

When the Pool/Spa output (for my setup this is Switch 5 on the PE653) is open this sets the heater to Pool mode and the heater will run when it detects water flow and the water temp is below the Pool set-point. When Switch 5 (PE653) is closed it triggers the heater to Spa heating mode and will heat to that set-point.

What type of pool heater do you have? Do you have the Make and Model number? I can look it up online and see if I can add any help.

Below is my Node-Red Flow for my setup:

I have not touched this since April when I made the switch. This, along with the Dashboard make all the wheels turn for my setup. Looking at it today I can probably tweak it a bit, to clean it up and maybe streamline it…someday! :slight_smile:

@stanman1958, the issue for me is not my heater. It too is a Rheem. The issue is that the PE653 has (2) setpoints for heating. One for when in Pool Mode (for which the zwave device uses heat setpoint) and one for the Spa Mode (for which the zwave device uses the cool setpoint). However, only the Pool setpoint shows up in zwavejsmqtt. No Spa setpoing. So when I turn on my spa, the heater will not turn on.

I think you are on V3.1 firmware for the PE653. I am on V3.9. I think that is why you get both setpoints and I only get 1. But I got both when I was using the ISY to control zwave. Using Home Assistant zwavejs do not work.