Internal Server Error while loading addons


when loading web UI of any addon i get this error:

# 500 Internal Server Error
Server got itself in trouble

console in browser:

GET http://homeassistant:8123/api/hassio_ingress/... 500 (Internal Server Error)

Supervisor log:

ERROR (MainThread) [aiohttp.server] Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.12/site-packages/aiohttp/", line 452, in _handle_request
    resp = await request_handler(request)
  File "/usr/local/lib/python3.12/site-packages/sentry_sdk/integrations/", line 139, in sentry_app_handle
  File "/usr/local/lib/python3.12/site-packages/sentry_sdk/", line 1640, in reraise
    raise value
  File "/usr/local/lib/python3.12/site-packages/sentry_sdk/integrations/", line 129, in sentry_app_handle
    response = await old_handle(self, request)
  File "/usr/local/lib/python3.12/site-packages/aiohttp/", line 543, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.12/site-packages/aiohttp/", line 114, in impl
    return await handler(request)
  File "/usr/src/supervisor/supervisor/api/middleware/", line 189, in block_bad_requests
    return await handler(request)
  File "/usr/src/supervisor/supervisor/api/middleware/", line 205, in system_validation
    return await handler(request)
  File "/usr/src/supervisor/supervisor/api/middleware/", line 224, in token_validation
    return await handler(request)
  File "/usr/src/supervisor/supervisor/api/middleware/", line 283, in core_proxy
    return await handler(request)
  File "/usr/src/supervisor/supervisor/api/", line 164, in handler
    return await self._handle_request(request, addon, path, session_data)
  File "/usr/src/supervisor/supervisor/api/", line 240, in _handle_request
    async with self.sys_websession.request(
  File "/usr/local/lib/python3.12/site-packages/aiohttp/", line 1197, in __aenter__
    self._resp = await self._coro
  File "/usr/local/lib/python3.12/site-packages/aiohttp/", line 606, in _request
    resp = await req.send(conn)
  File "/usr/local/lib/python3.12/site-packages/aiohttp/", line 723, in send
    await writer.write_headers(status_line, self.headers)
  File "/usr/local/lib/python3.12/site-packages/aiohttp/", line 129, in write_headers
    buf = _serialize_headers(status_line, headers)
  File "aiohttp/_http_writer.pyx", line 132, in aiohttp._http_writer._serialize_headers
  File "aiohttp/_http_writer.pyx", line 116, in aiohttp._http_writer._safe_header
    raise ValueError(
ValueError: Newline or carriage return character detected in HTTP status message or header. This is a potential security issue.


# Loads default set of integrations. Do not remove.

# Text to speech
  - platform: google_translate

automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

  themes: !include_dir_merge_named themes
    - url: /local/custom-lovelace/button-card.js
      type: module
    - url: /local/custom-lovelace/card-mod.js
      type: module
    - url: /local/custom-lovelace/digital-clock.js
      type: module
    - url: /local/custom-lovelace/kiosk-mode.js
      type: module
    - url: /local/community/lovelace-mushroom/mushroom.js
      type: module
    - url: /local/community/mini-media-player/mini-media-player-bundle.js
      type: module
    - url: /local/community/lovelace-header-cards/lovelace-header-cards.js
      type: module
    - url: /local/community/lovelace-card-mod/card-mod.js
      type: module
    - url: /local/community/lovelace-wallpanel/wallpanel.js
      type: module


 - platform: wake_on_lan
   name: mypc
   mac: *mac*
   host: *ip*
    service: hassio.addon_stdin
      addon: core_rpc_shutdown
      input: inputpc

I’ve had this problem for about a year now, so it’s not the HASS version. I didn’t need to deal with it, because the addons I used were either set only via configuration or I used something else instead (file editor => ssh via putty), until now when I need it for zigbee2mqtt (I can’t use z2m frontend when using HASS OS)

I read a lot of discussions on a similar topic but nothing.

I tried:

  • empty configuration.yaml
  • disable each addon
  • turn off integrations (mainly those that bridged for third-party devices or were from apple, because I found that they caused this to someone)
  • I changed the main http address from the original homeassistant

I don’t have http set in configuration.yaml or anything that could cause this (I think. I tried removing WOL).

This problem just appeared on its own one day, I didn’t change or adjust anything. I thought it was some poorly done update of some integration/addon/hass, so I thought it would disappear one day by itself, it didn’t.

Any idea?