International Space Station Sensor

Is possible to integrate in the attribute the current latitude and longitude? so is possible to to track it on a map

thanks

Would be possible…the problem is that you need to do some heavy scrolling to get your home zone in a visible scale.

I dont want to add it to home assistant map… but I want to track the latidude and longitudine with the camera: component in home assistant an example is owntracks and gmaps integration

Can you please take a look at?

And comment or give feedback on the PR if needed. Thanks.

Thanks for the info.
So if show_on_map: True I can see ISS on the hass integrated MAP right?

If the show_on_map: false I can see the long and lat in the attributes?

yes

Yes, both values are added to the state attributes.

that’s awesom… I’ll wait to test it when it will be merged… thanks

Was merged.

1 Like

you must try… it’s awesome… thanks :slight_smile:

- platform: generic
  name: ISS
  still_image_url: https://maps.googleapis.com/maps/api/staticmap?center={{ states.binary_sensor.iss.attributes.lat }},{{ states.binary_sensor.iss.attributes.long }}&zoom=5&size=500x500&maptype=roadmap&markers=color:blue%7Clabel:P%7C{{ states.binary_sensor.iss.attributes.lat }},{{ states.binary_sensor.iss.attributes.long }}
  limit_refetch_to_url_change: true
2 Likes

That’s a nice one. I will add it to the docs. Thanks.

you’r welcome :relaxed:

Is it possible to hide the sensor on the HA map but still show the location on the google maps side?

Yes, it is. Check the docs…

1 Like

When I change the binar sensor to show_on_map:False or remove show_on_map completely I get this however if I change to true I get the correct screen but then am stuck with the icon on my HA maps.

Works fine on dev with the sample from the docs.

camera:
  - platform: generic
    name: ISS
    still_image_url: https://maps.googleapis.com/maps/api/staticmap?center={{ states.binary_sensor.iss.attributes.lat }},{{ states.binary_sensor.iss.attributes.long }}&zoom=5&size=500x500&maptype=roadmap&markers=color:blue%7Clabel:P%7C{{ states.binary_sensor.iss.attributes.lat }},{{ states.binary_sensor.iss.attributes.long }}
    limit_refetch_to_url_change: true
binary_sensor:
  - platform: iss
    show_on_map: False

I have my binary sensor yaml seperate from my camera yaml thus seperating the above config could this be the issue? Sorry to sound like a Noob!

I also got Map error on the top right with nothing.
Any solution?

I have the same issue where I get a google API error. I have an API key, and have the following in my camera.yaml file:

- platform: generic
  name: ISS_GoogleAPIS
  still_image_url: https://maps.googleapis.com/maps/api/staticmap?center={{ states.binary_sensor.iss.attributes.lat }},{{ states.binary_sensor.iss.attributes.long }}&zoom=10&size=500x500&maptype=roadmap&markers=color:red%7Clabel:S%7C{{ states.binary_sensor.iss.attributes.lat }},{{ states.binary_sensor.iss.attributes.long }}&key=SHHDONTTELLANYONEMYAPIKEY
  limit_refetch_to_url_change: true

I also have Camera and binary sensors separated, but I’m not sure that would make a difference.

how you have generated the api key for google maps? I can’t found on https://console.cloud.google.com

once you are logged in, click “select a project” (top left) and then create a “New project.”

create the project, then select it from the drop down at the top of the previous page. Then you can select Enable API’s and Services (again at the top of the page) and enable the APIs you need.