Make sure you have hassio: component or discovery: component loaded.

Thanks, that was it. Tested some configuration where discovery was disabled.
Inserted hassio:

How small was too small?

8GB. Virtualbox VM for testing.

1 Like

On time to update, you have 2 homeassistant docker. If the new docker is okay, we Switch to new homeassistant docker and remove the old. But for 30sec you have 2 homeassistant docker present on your system.

@pvizeli Hello, you said here : Release Notes
“Local repository build now add-on local if no image is set”

Does it mean that using Docker Hub is not mandatory anymore ?
And that it will build the Dockerfile located in the add-on folder ? :

In case someone new to Docker encounters the same problem (took me half an hour before I asked stackoverflow):

If while using the build-script you get the error

denied: requested access to the resource is denied

doing a docker login on the shell and entering your credentials does the authentication that’s required to push to your repo.

Yes. If you but a add-on to local repository, it will build it on device if no image is set.

Yeah you need login on dockerhub. Please make a note to doc, that would be nice

I’ve tried using the SSH option in, generated a key with Putty, loaded the key in Putty but it keeps saying “Server refused our key”


Ok, I have the SSH server working on Port:22222
That was the user root, I kept trying Pi etc.

Same with Port 22 that’s also root.

Now to sort Samba :slight_smile:

Joining the train and installed it yesterday! Now I’m just waiting for the open Zwave control panel containers before I can migrate my environment and start testing it on the missy :slight_smile:

Running it on a virtual Ubuntu 17.04 machine.
I’m totaly new to the docker concept, and a complete linux newbie, so creating my own addons is a big step :stuck_out_tongue:

Thanks for the solution so far! Realy hope this could be the next big thing, i really like the concept.


is it possible to use custom components? I have them in a custom_components folder but are not loading

I’m experiencing a weird issue where zwave entities do no use the friendly_name provided but just use the entity name bases friendly_name instead.

I experienced the same issue. eventually obtained a key on port 22222. ssh [[email protected]] -p 22222. What was the password?

User root with no Password

Hi DaleRobins,

Thanks for your response. But hitting the enter key on password prompt comes up with “Permission Denied”

Did you put a ssh key on the root of the SD card, is it in the correct format and filename?

Have a look here:

Hello everyone.

I started recently my journey into Home Assistant and after having installed it via Hassbian image and customized it a lot, I now stumbled into

After reading a bit, it is not clear to me if this can be installed over such an existing installation or if I need to start with which will install Home Assistant.

I read here, but not totally sure if it’s going to work the same exact way.

Has anyone tried this and can provide any insights?

Thanks in advance.

Backup your configuration folder, then install ‘clean’, after that works you can restore your configuration files.

Ok thanks.

I will put the image on a new SD card for testing purposes.

Btw, the underlying OS for is not Raspbian, is it? Is it still Debian based?

Thanks in advance.