Introducing Hass.io


#1

While developing Home Assistant we realized that a lot of users will end up running many different applications together. You want to use Mosquitto as your MQTT broker, you want Homebridge to integrate HomeKit and you want to use Samba so that you can easily edit your configuration from your main computer.

To make all these tasks a lot easier Fredrik Lindqvist introduced Hassbian for the Raspberry Pi: a flavor of the Raspbian operating system that automatically installs Home Assistant and allows for easy installation of supporting applications for Home Assistant. However, after installation of Home Assistant and apps you were on your own. Future upgrades would require manual work and there was no longer any handholding. On top of that there was the challenge of configuring all these extra applications.

So I started a couple of months ago on a mission to come up with a solution for users to easily manage their Home Assistant server and related applications. Meet hass.io.

Hass.io is a new way of running Home Assistant based on Docker and ResinOS. The core part of the system is the hass.io supervisor. The supervisor is in control of your system and is able to launch and update Home Assistant and any of the applications that you will need.

Any application that you want to run can be added via an add-on. Hass.io will come with a few built-in add-ons to share your config using Samba, run Mosquitto and automatically generate or renew your Let’s Encrypt certificates.

We also made it very easy to create your own add-ons using Dockerfiles. Hass.io will also allow you to share repositories of add-ons with the community. That way, having someone use your new application that works on Home Assistant is as easy as having them install an add-on from your repository!

The beta starts today and we have images available for Raspberry Pi and an installation script to get it running on an i386 or amd64 linux server.

Note that this is a beta. We have been running this for a while and it’s stable. However there might still be some rough edges. Please report any issues back to us here on the forums.

Once we consider this good enough we’ll go for a mainstream release. Because we don’t want the public to use this yet, the documentation is not linked yet from our homepage: https://home-assistant.io/hassio/.

Big thanks to @balloob for helping me with the configuration panel and all the administrative stuff.

How you can help:

Note: Hass.io currently can be controlled by anyone who has access to your Home Assistant instance. Since we support custom add-ons, this means that anyone with access can run any application on your machine. Do not connect your hass.io instances to the internet. This will be addressed in a future release.


SIP (VoIP) Monitoring for incoming calls using MQTT
Repository: Homebridge add-on
Home Assistant 0.45: Automation editor, Z-Wave panel, OCR
pinned #2

#3

so this is an alternative to AIO, hassbian ver x.x ?


#4

Installed on a ubuntu 16.04 VM using this instruction.
[ERROR] Please install docker first
Installed docker Get Docker for Ubuntu
After this the install command runs and finaly i can acces HA on IP_of_VM:8123

@pvizeli, this is awesome!!

How can i install Built-in addons?
After klicking an a addon i get only a white frame, nothing else.
Have to reload the Hass.io frame and addons states ‘Not installed’


#5

Looks very interesting, I just have one Raspberry Pi currently running AIO. I want to try this out, but will se how to make it happen.


#6

Look like we have a bug inside UI. We want fix it soon.


#7

Great stuff. I think this will make HA much more usable. I will try to contribute with testing and documentation.


#8

The bug with white on addon install page will be fix with 0.44.1 and they coming soon. Thanks for reporting


#9

Awesome! Would zwave support possible? (or is this an example of a future addon?)


#10

Log shows UTC Time.
UI Time (sensor time_date +2h) is OK
Bash in the container shows UTC also:

bash-4.3# date
Sun May  7 21:06:19 UTC 2017

Maybe some --volume /etc/localtime:/etc/localtime:ro, when running the image?
I’m tinkering a few days with docker and use this for every image.


#11

zwave should be already included


#12

Restarting HA with Configuration/Restart or Hass.io/Homeassistant/Restart ends in:

2017-05-07 21:31:31 WARNING (MainThread) [aiohttp.websocket] websocket connection is closing.
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/__main__.py", line 4, in <module>
    import argparse
  File "/usr/local/lib/python3.6/site-packages/argparse.py", line 93, in <module>
    import re as _re
  File "/usr/local/lib/python3.6/re.py", line 142, in <module>
    class RegexFlag(enum.IntFlag):
AttributeError: module 'enum' has no attribute 'IntFlag'

Have to service hassio-supervisor restart to get HA back.


#13

How to update Hass.io / Homeassistant?


#14

If we publish it, you can see it on UI.

We start the build of 0.44.2 while 0.44.1 had not fix the bug. I think in 2-3 hours you can see the update on your panel. To force fetch version, you can call “restart” on supervisor card. But call in first in 3 hours, before it will not change.

Edit
Update public now


#15

@pvizeli, Supervisor update worked. Now on 0.22.
HA Card shows current 0.44, latest 0.44.2.
After klick on Update it spins a while, then klick on Restart ends in the error postet above.
After hassio-supervisor restart HA is already on 0.44. Also host restart did not help.
Are there any logs about this?


#16

Klick update and wait until you see the new version. The time for update is depens on speed of SD card and internet brandwith.

I think the restart buttin is brocken. It is only a service call. I will move that to supervisor. That will also help that is not possible to call restart on update.


#17

Puuh, took some time for this.
Nothing helped. After removing the image and run manually in a terminal i found the problem.

[email protected]:~# docker run homeassistant/qemux86-64-homeassistant
Unable to find image 'homeassistant/qemux86-64-homeassistant:latest' locally
latest: Pulling from homeassistant/qemux86-64-homeassistant
...
docker: failed to register layer: Error processing tar file(exit status 1): write /usr/local/lib/python3.6/unittest/test/testmock/testpatch.py: no space left on device.
See 'docker run --help'.

The disk of my VM was a little to small for 0.44.2, but 0.44 worked. :unamused:
Also install of Addons works now.
Thanks once again @pvizeli


#18

On the pi3 running hass.io can run other programs like pi-hole and others?


#19

Yes as add-ons. Feel you free and create a addon for that or post to Add-on ideas


#20

Only as add-ons?