Invalid checksum for backup superblock

For last time I found HA OS have some errors during startup process.
Is it critical? Is it possible to fix?

HA OS running as VM on Proxmox.

I would expect that the ext4 file system would repair those superblock checksums automatically since those are backup superblocks. Does the error persist on reboot?

It is a bit concerning that those backup superblock checksums suddenly didn’t match. It sounds like some kind of disk corruption. Did you had power outage? Otherwise it could be a failing disk. Definitely make sure to have a full backup downloaded of that installation.

have daily backup of this VM.
Error seen only when machine starting up.

should I run any kind of disk check on Proxmox level, to see if physical disk is ok?

I have also experienced these messages on two systems. Both these systems behaved “strange”. I honestly do not remember the exact errors I got but on one system I got some error with the Supervisor which seem to made one add-on not to work. On another system, suddenly various and several integrations were not loaded. They worked fine for a while and then they just stopped working and reported that they were not loaded.

Running the following command from the host OS:

journalctcl -k -b 0 -g ‘mmc’

I get:

@agners, do you happen to know how to proceed with this? I can try to dig more if someone have ideas what to dig for. :slight_smile:

A duckduckgo search for "“invalid checksum for backup superblock” and “ext4” resulted in this thread and the following: