IOS 12.2.2 Beta breaks IOS App 1.5


#1

App will start but seems to not be able to display the Lovelace UI’s. Just a blank screen appears.

Using the IOS Safari 12.2.2 also does the same.


#2

Haven’t tried it yet (still on the first beta) however you could try the home assistant beta app. This had fixed many problems with ios beta’s in the past (as in, the released version wouldn’t work on ios beta’s).

You can get the beta version of Home Assistant by clicking on the above link.


#3

Thanks, but I have tried this and it’s also a problem with the current latest released build #34.


#4

Ouch, what you could try is enabling some (or all) of the experimental features of Safari (this was another solution which had worked for me in the past). If this doesn’t work then I am out of ideas haha.

Go to Settings>Safari>Advanced>Experimental Features


#5

I’m on both betas as well, no major issues yet…

Sometimes my weather card doesn’t Work but after clearing safari in the settings it usually clears it up.


#6

Public Beta 2 and released 1.5 iOS app seems ok for me… (I am on HA Beta 0.87.0b6 though)


#7

Same here no issues with latest public release and 0.87.b5


#8

Hmmm, let me test once 87 comes out. But I have a iPad and iPhone on 12.1.x working fine; and a iPhone on 12.2b2 that isn’t.


#9

Everyone,

I solved this by:

  1. Wiping device to a base install of 12.2b2

  2. Reinstall the HA app, and re-set the settings

  3. Works

I can only assume as this phone has gotten many iOS betas and HA betas something was in a odd state; and wiping got me back to a known clean state.