(IOS 14) Notifications not working

Tags: #<Tag:0x00007f7397a694d0>

After updating to iOS 14 my notifications are not working anymore. I am using the developer tools notify.mobile_app_XXXXX with de message en title. Sending it to another device does work.

It started working all of a sudden. Don’t know what changed.

MIne is still not working…

I saw another post with the following steps:

  1. Log out and remove the Home Assistant app
  2. Log in to Home Assistant and remove all devices in the Mobile App intergration
  3. Restart Home Assistant
  4. Install the app again and try again

Here’s the deal for me. I had the same issue and removed the app, removed the phone from HA. My other family member’s iPhone with iOS 13 was fine. So after redoing everything I’m getting “A” notice, but not all of them. However for me it’s due to the fact that the direction information isn’t populating for the phone and for some of my notifications that is relevant to triggering. Worked fine pre iOS 14 but now just sits at Unknown. So still not 100% sure the notifications are working, but I do get some of them.