iOS 2.0 App: Cannot login

Looked at the other topics, but nothing helped. My app was updated to 2.0 and now I cannot login anymore.

I use duckdns and letsencrypt. Logging in on the mobile web page on iPhone/iOS works just fine, so it must be a problem with the app.

  • Some genius figured out that Dutch is apparently the language I want, cannot change it.
  • App detects my Home Assist properly.
  • When I select it, I get a big red cross with “Uh Oh!” “Onbekende fout: Geen verbinding met de server mogelijk” which translates to “Unknown error, no connection with the server possible”.
  • Pressing the “More information” button redirects to “Page Not Found”, Smooth sailing guys!

Nothing appears in the log (or I don’t know where to look). I have “default_config:” in my config file and added “ios:”. Tried enabling/disabling IPv6 on my router. Rebooted RP several times, upgraded to latest version, tried in and outside my local network but nothing helps. As I said: can access it just fine in any browser, mobile or not and on WiFi or not so it must be the app.

Anyone any suggestions?

(and by the way, I spend last weekend trying to figure out why I couldn’t log in at all anymore. Turned out the Duck DNS add-in did not update the SSL certificate. That is fixed now, but not that amused with the way things are going now…)

Chances are your base_url does not match the duckdns url fully. Try manually entering the url to see if that’s it.

Hey thanks! I was just about to say: nope, tried that dozens of times, but got me thinking: base_url contains the port number (as in the example here: https://www.home-assistant.io/addons/duckdns/).

Perhaps it should not? Without it the app works!

I have the same problem that the new homeassistant ios app does not give me a ‘login’ screen and fails with ‘uh oh’ when the ‘authentication’ times out.
Could you please explain in more detail what you did to make it work?

I can access homeassistant from any browser (also on the iphone). In my configuration.yaml, I had my base_url defined to be the duckdns url without the port. I have tried with and without defining server_port. I have not upgraded homeassistant, so I am running version 0.99.

I did not do anything different. My base_url is with port, but in the app I selected “manually enter” and entered it without the port.

Earlier I tried updating to the latest home assistant version, enabling IPv6 on my router and updating the “Host system” (now on HassOS 2.12). Didn’t help but perhaps it’s the combination of one of these things and leaving the port out when manually entering the address.