Ios app and weblinks


#1

Hi. Has something changed? Recently with weblinks in the ios app they would open within the app instead of opening a separate webpage in safari or chrome. This was much more beneficial to me as it hid the ip address from a security standpoint but also visually allowed the page to be displayed at a bigger size. Also being within the app it allowed me to navigate easier instead of having to switch between safari and the ios app. Is there an option I missed that allows me to switch back the behavior? Thanks for the help!


#2

Still working for me, how did you do the weblink formatting? I use something like this:

       -  type: entities
          entities:
            - type: weblink
              name: Outlook
              url: ms-outlook://
            - type: weblink
              name: PostNL
              url: postnl://
            - type: weblink
              name: Calendar
              url: weekcal://
            - type: weblink
              name: Bunq
              url: bunq://
            - type: weblink
              name: Maps
              url: maps://
            - type: weblink
              name: Apple Music
              url: music://
            - type: weblink
              name: Plex
              url: plex://

I do not use weblinks from my configuration.yaml, I only use this configuration in lovelace. You don’t need to set up weblinks in your configuration.yaml for this.


#3

I have it like this but tried your way and same result…still opens it in safari


#4

What app is it supposed to open with that address? Seems like a router page or something.


#5

Logitech media server. It was working fine recently. Not sure what changed. I upgraded to HA 0.87.1.


#6

Links have never opened in the app for me. They have always opened in Chrome or Safari depending on the “Open in Chrome” setting.


#7

It definielty worked. Frustrating. Can’t figure out what changed