iOS app can’t get out of integration config screen

Tags: #<Tag:0x00007fc41e175630> #<Tag:0x00007fc41e175400>

I’m stuck on the zwave integration configuration screen. I can’t find any way to get out of it. The back arrow does nothing except flicker the current screen. I’ve tried pulling down to reload. I’ve tried killing the app and re-opening. The app is totally useless to me now, which really sucks. Anyone else had this problem before?

looks like https://github.com/home-assistant/frontend/issues/8514 ? If so, please +1 that

That link is possibly related, but no amount of pressing the back arrow will get me out of that screen on the mobile app. Restarting the app is equally ineffective. The app is permanently stuck on that page and completely useless.

The iOS app will ‘forget’ which page you were last on if you force-quit it (and wait a few seconds before re-launching). The app uses the system’s methods for doing restoration of this, and force-quitting throws away that information.

Some configuration screens that you can get ‘stuck’ on visually still allow you to use the left-swipe-from-edge gesture to reveal the sidebar menu.

I had tried force-quitting, but maybe I didn’t wait long enough before re-launching. I eventually got it to forget the current page by force-quitting, turning off wifi and then launching while on cellular data. It’s possible that turning off the wifi only resulted in enough time elapsing before re-launching and it was the same as your suggestion. Hard to say. It was quite frustrating. I didn’t know about swiping in from the left to get the menu. That would have definitely gotten me out of that screen very easily. Thanks for the tip!