iOS App: cannot exit plugin

I just installed Scrypted as an add-on. It works great! Unfortunately I’m permanently locked inside it as far as the mobile app is concerned. I’ve tried force-killing, waiting 5 minutes, and restarting the HA app, but when I restart it goes directly to Scrypted and won’t exit. The developer of Scrypted says this particular UI component is a Home Assistant feature and this bug falls here, not with his add-on.

Any ideas how to exit the plugin?

Server side is Synology device running HAOS on the official virtual machine.

wow - force-killing the app doesn’t work.

Total guess, but how about:

  1. Disabling the plugin from your PC
  2. Force-kill the app on your iPhone
  3. Restart the app on your iPhone
  4. Re-activate the plugin from the PC

…if that works, number 5 is: never go to the plug-in from the iPhone :wink:

Good workaround idea - I’ll try thatedit: that worked! I also just did some experimentation with Android and it’s not a problem there. Android puts the full HAOS hamburger menu in the upper left, instead of a single-purpose exit button, and that hamburger is still accessible and works fine.

edit: desktop computer, web management console, stop Scrypted, force kill app, wait, reopen, still get Scrypted but now it’s an error modal with only “ok, I see this error” (effectively) as a confirmation button, press that, then you’re back to normal UI and can navigate.

Let us know if it works (or not).

It did. Workaround valid (see my edit above). I’m going to be careful not to touch Scrypted from iOS for now!

1 Like